mask e-file for removal.
[gentoo-china-overlay.git] / x11-themes / ubuntu-mono / ubuntu-mono-0.0.20.ebuild
blob68dd5edacfbe3f325f90b64a476407fe691671d9
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 EAPI="2"
7 inherit gnome2-utils
9 DESCRIPTION="Dark and Light panel icons to make your desktop beautiful"
10 HOMEPAGE="http://www.ubuntu.com/"
11 SRC_URI="mirror://ubuntu/pool/main/u/${PN}/${PN}_${PV}.tar.gz"
13 LICENSE="CCPL-Attribution-ShareAlike-3.0"
14 SLOT="0"
15 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
16 IUSE=""
18 RDEPEND="
19         >=x11-misc/icon-naming-utils-0.8.90
20         media-gfx/imagemagick
21         >=gnome-base/librsvg-2.26.0
22         >=x11-themes/hicolor-icon-theme-0.10
23         x11-themes/humanity-icon-theme"
24 DEPEND="${RDEPEND}
25         dev-util/pkgconfig
26         dev-util/intltool
27         sys-devel/gettext"
29 RESTRICT="binchecks mirror strip"
31 src_install() {
32         dodir /usr/share/icons
33         cp -r LoginIcons ${PN}* "${D}"/usr/share/icons || die "install failed."
35         dodoc "${S}"/debian/{changelog,copyright} || die "install doc failed."
38 pkg_preinst() { gnome2_icon_savelist; }
39 pkg_postinst() { gnome2_icon_cache_update; }
40 pkg_postrm() { gnome2_icon_cache_update; }