Nuking git-alsa-utils per reports of segfaulting. (initscript vs alsactl init?)
[gentoo-diskmaster-overlay.git] / media-plugins / alsa-plugins / alsa-plugins-1.0.17-r2.ebuild
blobe409b2de7842f2d72e93a3cc3eb483540584781d
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/www/viewcvs.gentoo.org/raw_cvs/gentoo-x86/media-plugins/alsa-plugins/alsa-plugins-1.0.17-r1.ebuild,v 1.1 2008/08/06 22:37:28 yngwin Exp $
5 inherit libtool autotools eutils flag-o-matic
7 MY_P="${P/_/}"
9 DESCRIPTION="ALSA extra plugins"
10 HOMEPAGE="http://www.alsa-project.org/"
11 SRC_URI="mirror://alsaproject/plugins/${MY_P}.tar.bz2"
13 LICENSE="GPL-2 LGPL-2.1"
14 SLOT="0"
15 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
16 IUSE="debug ffmpeg jack libsamplerate pulseaudio speex"
18 RDEPEND=">=media-libs/alsa-lib-${PV}
19         ffmpeg? ( media-video/ffmpeg )
20         jack? ( >=media-sound/jack-audio-connection-kit-0.98 )
21         libsamplerate? ( media-libs/libsamplerate )
22         pulseaudio? ( media-sound/pulseaudio )
23         speex? ( media-libs/speex )
24         !media-plugins/alsa-jack"
26 DEPEND="${RDEPEND}
27         dev-util/pkgconfig"
29 S="${WORKDIR}/${MY_P}"
31 src_unpack() {
32         unpack ${A}
33         cd "${S}"
35         epatch "${FILESDIR}/${PN}-1.0.17-automagic.patch"
36         epatch "${FILESDIR}/${PN}-1.0.14_rc1-init-ffmpeg.patch"
37         epatch "${FILESDIR}"/ffmpeg-headers.patch
38         epatch "${FILESDIR}"/git-update.patch
40         # For some reasons the polyp/pulse plugin does fail with alsaplayer with a
41         # failed assert. As the code works just fine with asserts disabled, for now
42         # disable them waiting for a better solution.
43         sed -i -e '/AM_CFLAGS/s:-Wall:-DNDEBUG -Wall:' \
44                 "${S}/pulse/Makefile.am"
46         eautoreconf
47         elibtoolize
50 src_compile() {
51         use debug || append-flags -DNDEBUG
53         econf \
54                 $(use_enable ffmpeg avcodec) \
55                 $(use_enable jack) \
56                 $(use_enable libsamplerate samplerate) \
57                 $(use_enable pulseaudio) \
58                 $(use_with speex speex lib) \
59                 --disable-dependency-tracking \
60                 || die "econf failed"
61         emake || die "emake failed"
64 src_install() {
65         emake DESTDIR="${D}" install
67         cd "${S}/doc"
68         dodoc upmix.txt vdownmix.txt README-pcm-oss
69         use jack && dodoc README-jack
70         use libsamplerate && dodoc samplerate.txt
71         use pulseaudio && dodoc README-pulse
72         use ffmpeg && dodoc lavcrate.txt a52.txt