games-engines/qtads: fix live ebuild deps
[gentoo-interactive-fiction.git] / games-engines / fizmo / fizmo-0.8.5.ebuild
blobc58850b12ae5ef314bab9c4098ae539256d78b56
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 EAPI=4
7 inherit eutils
9 DESCRIPTION="Yet another Z-machine interpreter"
10 HOMEPAGE="http://www.spellbreaker.org/~chrender/fizmo/"
11 SRC_URI="http://www.spellbreaker.org/~chrender/fizmo/source/${P}.tar.gz"
13 LICENSE="BSD"
14 SLOT="0"
15 KEYWORDS="amd64 x86"
16 IUSE="+aiff +jpeg +png +X"
17 REQUIRED_USE="jpeg? ( X ) png? ( X )"
19 RDEPEND="jpeg? ( virtual/jpeg:0 )
20         png? ( media-libs/libpng )
21         X? ( x11-libs/libX11 )
22         sys-libs/ncurses[unicode]
23         media-libs/libsdl2
24         aiff? ( media-libs/libsndfile )
25         dev-libs/libxml2"
26 DEPEND="${RDEPEND}
27         virtual/pkgconfig"
29 DOCS="CHANGELOG.txt LICENSE.txt README.txt user-config-example.txt"
31 src_configure() {
32         econf \
33                 $(use_enable aiff) \
34                 $(use_enable jpeg) \
35                 $(use_enable png) \
36                 $(use_enable X x11)
39 src_install() {
40         emake DESTDIR="${D}" install
41         dodoc ${DOCS}