games-engines/qtads: fix live ebuild deps
[gentoo-interactive-fiction.git] / games-engines / glkfrotz / glkfrotz-2011.1.ebuild
blob95059245fdbd3b70cb682d57767f10ae50cd5b52
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 inherit toolchain-funcs games
7 DESCRIPTION="Glk-based interpreter for Z-code based text games"
8 HOMEPAGE="http://frotz.sourceforge.net/ http://ccxvii.net/gargoyle/ http://code.google.com/p/garglk/"
9 SRC_URI="http://garglk.googlecode.com/files/gargoyle-${PV}-sources.zip"
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
16 RDEPEND=">=dev-games/glkloader-0.3.2-r3
17 !<dev-games/cheapglk-0.9.0-r1
18 !=dev-games/garglk-2006*
19 !=dev-games/garglk-2008*
20 !<dev-games/glkterm-0.8.0-r1
21 !<dev-games/glktermw-0.8.0-r2
22 !<dev-games/xglk-0.4.11-r1"
23 DEPEND="${RDEPEND}
24 app-arch/unzip
25 >=dev-games/glk-headers-0.7.0-r1"
27 S=${WORKDIR}/terps/frotz
29 src_compile() {
30 $(tc-getCC) ${CPPFLAGS} -I/usr/include/glk ${CFLAGS} *.c -o glkfrotz ${LDFLAGS} -lglkloader || die "cc failed"
33 src_install() {
34 dogamesbin glkfrotz || die "dogamesbin failed"
35 dodoc README TODO AUTHORS || die "dodoc failed"
36 prepgamesdirs