1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
5 inherit toolchain-funcs games
7 DESCRIPTION
="Glk-based interpreter for Z-code based text games"
8 HOMEPAGE
="http://frotz.sourceforge.net/ http://ccxvii.net/gargoyle/ http://code.google.com/p/garglk/"
9 SRC_URI
="http://garglk.googlecode.com/files/gargoyle-${PV}-sources.zip"
13 KEYWORDS
="~amd64 ~x86"
16 RDEPEND
=">=dev-games/glkloader-0.3.2-r3
17 !<dev-games/cheapglk-0.9.0-r1
18 !=dev-games/garglk-2006*
19 !=dev-games/garglk-2008*
20 !<dev-games/glkterm-0.8.0-r1
21 !<dev-games/glktermw-0.8.0-r2
22 !<dev-games/xglk-0.4.11-r1"
25 >=dev-games/glk-headers-0.7.0-r1"
27 S
=${WORKDIR}/terps
/frotz
30 $
(tc-getCC
) ${CPPFLAGS} -I/usr/include/glk ${CFLAGS} *.c -o glkfrotz ${LDFLAGS} -lglkloader || die
"cc failed"
34 dogamesbin glkfrotz || die
"dogamesbin failed"
35 dodoc README TODO AUTHORS || die
"dodoc failed"