app-misc/gnome-commander: 1.3.0.99 - adjust dep for app-doc/chmlib -> dev-libs/chmlib...
[gentoo-soor-overlay.git] / app-misc / gnome-commander / gnome-commander-1.3.0.99.ebuild
blob4f876ac629365c7eac1ebe988a87a7e6f29be3c5
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License, v2 or later
3 # $Header:
5 EAPI="1"
7 inherit gnome2 flag-o-matic subversion autotools
9 DESCRIPTION="A full featured, dual-pane file manager for Gnome2"
10 HOMEPAGE="http://www.nongnu.org/gcmd/"
12 ESVN_REPO_URI="svn://svn.gnome.org/svn/gnome-commander/branches/gcmd-1-3"
13 SRC_URI=""
15 KEYWORDS=""
17 LICENSE="GPL-2"
19 IUSE="doc chm exif gsf taglib python"
20 SLOT="0"
22 USE_DESC="chm: add support for Microsoft Compiled HTML Help files
23                   exif: add support for Exif and IPTC
24                   gsf: add support for OLE, OLE2 and ODF
25                   taglib: add support for ID3, Vorbis, FLAC and APE
26                   python: add support for python plugins"
28 RDEPEND=">=x11-libs/gtk+-2.8.0:2
29                  >=dev-libs/glib-2.6.0:2
30                  >=gnome-base/libgnomeui-2.4.0
31                  >=gnome-base/libgnome-2.4.0
32                  >=gnome-base/gnome-vfs-2.0.0
33                  virtual/fam
34                  chm?    ( >=dev-libs/chmlib-0.39      )
35                  exif?   ( >=media-gfx/exiv2-0.14      )
36                  gsf?    ( >=gnome-extra/libgsf-1.12.0 )
37                  taglib? ( >=media-libs/taglib-1.4     )
38                  python? ( >=dev-lang/python-2.4       )"
40 DEPEND="${RDEPEND}
41                 gnome-base/gnome-common
42                 dev-util/intltool
43                 dev-util/pkgconfig"
45 DOCS="AUTHORS BUGS ChangeLog NEWS README TODO"
47 pkg_setup() {
48         G2CONF=" ${G2CONF}
49                          $(use_with   chm    chmlib)
50                          $(use_with   exif   exiv2 )
51                          $(use_with   gsf    libgsf)
52                          $(use_with   taglib taglib)
53                          $(use_enable python python)"
55         filter-ldflags -Wl,--as-needed
58 src_unpack() {
59         subversion_fetch || die "svn fetch failed"
61         cd "${S}"
63         gnome2_omf_fix || die "Gnome2 OMF Fix failed"
65         # implement autogen.sh with eclass tools
66         rm -rf autom4te.cache
67         autotools_run_tool libtoolize --force --copy
68         autotools_run_tool glib-gettextize --force --copy
69         autotools_run_tool intltoolize --force --copy --automake
70         autotools_run_tool gnome-doc-common --copy
71         autotools_run_tool gnome-doc-prepare --force --copy
72         eaclocal
73         eautoconf
74         eautoheader
75         eautomake --force
77         elibtoolize ${ELTCONF} || die "elibtoolize failed"