1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License, v2 or later
7 inherit gnome2 flag-o-matic subversion autotools
9 DESCRIPTION="A full featured, dual-pane file manager for Gnome2"
10 HOMEPAGE="http://www.nongnu.org/gcmd/"
12 ESVN_REPO_URI="svn://svn.gnome.org/svn/gnome-commander/branches/gcmd-1-3"
19 IUSE="doc chm exif gsf taglib python"
22 USE_DESC="chm: add support for Microsoft Compiled HTML Help files
23 exif: add support for Exif and IPTC
24 gsf: add support for OLE, OLE2 and ODF
25 taglib: add support for ID3, Vorbis, FLAC and APE
26 python: add support for python plugins"
28 RDEPEND=">=x11-libs/gtk+-2.8.0:2
29 >=dev-libs/glib-2.6.0:2
30 >=gnome-base/libgnomeui-2.4.0
31 >=gnome-base/libgnome-2.4.0
32 >=gnome-base/gnome-vfs-2.0.0
34 chm? ( >=dev-libs/chmlib-0.39 )
35 exif? ( >=media-gfx/exiv2-0.14 )
36 gsf? ( >=gnome-extra/libgsf-1.12.0 )
37 taglib? ( >=media-libs/taglib-1.4 )
38 python? ( >=dev-lang/python-2.4 )"
41 gnome-base/gnome-common
45 DOCS="AUTHORS BUGS ChangeLog NEWS README TODO"
49 $(use_with chm chmlib)
50 $(use_with exif exiv2 )
51 $(use_with gsf libgsf)
52 $(use_with taglib taglib)
53 $(use_enable python python)"
55 filter-ldflags -Wl,--as-needed
59 subversion_fetch || die "svn fetch failed"
63 gnome2_omf_fix || die "Gnome2 OMF Fix failed"
65 # implement autogen.sh with eclass tools
67 autotools_run_tool libtoolize --force --copy
68 autotools_run_tool glib-gettextize --force --copy
69 autotools_run_tool intltoolize --force --copy --automake
70 autotools_run_tool gnome-doc-common --copy
71 autotools_run_tool gnome-doc-prepare --force --copy
77 elibtoolize ${ELTCONF} || die "elibtoolize failed"