dev-python/conda-package-handling: add 2.4.0, drop 2.3.0
[gentoo-zh.git] / net-misc / biliup-app-bin / biliup-app-bin-0.4.1.ebuild
blob4f36630e10c18d9689b392273a746865e24e730c
1 # Copyright 2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit unpacker xdg
8 MY_PN="biliup-app"
10 DESCRIPTION="A Tool for Upload video to bilibili"
12 HOMEPAGE="https://github.com/ForgQi/biliup-app"
13 SRC_URI="https://github.com/ForgQi/${MY_PN}/releases/download/app-v${PV}/${MY_PN}_${PV}_amd64.deb"
15 RESTRICT="mirror strip"
17 LICENSE="0BSD Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD Boost-1.0 CC0-1.0 ISC MIT MIT-0 MPL-2.0 Unicode-DFS-2016 Unlicense ZLIB"
18 SLOT="0"
19 KEYWORDS="~amd64"
21 RDEPEND="
22         net-libs/webkit-gtk:4
23         x11-libs/gtk+:3
24         !net-misc/biliup-app
27 S="${WORKDIR}"
29 MY_PREFIX="opt/apps/${MY_PN}"
31 src_install()
33         insinto /
34         doins -r .
35         fperms 0755 /usr/bin/biliup-app