1 # Copyright 2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 # Autogenerated by pycargoebuild 0.13.2
51 bytecheck_derive@0.6.12
65 cocoa-foundation@0.1.2
67 concurrent-queue@2.5.0
72 core-foundation-sys@0.8.6
74 core-graphics-types@0.1.3
78 crossbeam-channel@0.5.12
79 crossbeam-utils@0.8.19
90 derive_is_enum_variant@0.1.1
97 documented-derive@0.4.1
106 enumflags2_derive@0.7.9
109 event-listener-strategy@0.4.0
110 event-listener-strategy@0.5.2
118 foreign-types-macros@0.2.3
119 foreign-types-shared@0.1.1
120 foreign-types-shared@0.3.1
123 form_urlencoded@1.2.1
125 from_variants_impl@1.0.2
127 futures-channel@0.3.30
129 futures-executor@0.3.30
136 gdk-pixbuf-sys@0.18.0
137 gdk-pixbuf-sys@0.19.5
200 libappindicator-sys@0.9.0
201 libappindicator@0.9.0
206 libmimalloc-sys@0.1.38
222 minimal-lexical@0.2.1
238 objc-foundation@0.1.1
257 parking_lot_core@0.9.10
259 percent-encoding@2.3.1
264 pin-project-internal@1.1.5
265 pin-project-lite@0.2.14
277 proc-macro-crate@1.3.1
278 proc-macro-crate@2.0.0
279 proc-macro-crate@3.1.0
280 proc-macro-error-attr@1.0.4
281 proc-macro-error@1.0.4
285 ptr_meta_derive@0.1.4
294 raw-window-handle@0.6.1
297 regex-automata@0.1.10
309 rust_decimal_macros@1.34.2
310 rustc-demangle@0.1.23
314 rustls-pki-types@1.5.0
320 security-framework-sys@2.10.0
321 security-framework@2.10.0
328 serde_urlencoded@0.7.1
331 signal-hook-registry@1.4.2
342 static_assertions@1.1.0
355 system-configuration-sys@0.5.0
356 system-configuration@0.5.1
359 target-lexicon@0.12.14
363 thiserror-impl@1.0.59
372 tokio-native-tls@0.3.1
384 tracing-attributes@0.1.27
386 tracing-journald@0.3.0
388 tracing-subscriber@0.3.18
396 unicode-normalization@0.1.23
397 unicode-segmentation@1.11.0
406 version-compare@0.2.0
411 wasi@0.11.0+wasi-snapshot-preview1
412 wasm-bindgen-backend@0.2.92
413 wasm-bindgen-futures@0.4.42
414 wasm-bindgen-macro-support@0.2.92
415 wasm-bindgen-macro@0.2.92
416 wasm-bindgen-shared@0.2.92
419 winapi-i686-pc-windows-gnu@0.4.0
420 winapi-x86_64-pc-windows-gnu@0.4.0
423 windows-implement@0.56.0
424 windows-interface@0.56.0
428 windows-targets@0.48.5
429 windows-targets@0.52.5
431 windows_aarch64_gnullvm@0.48.5
432 windows_aarch64_gnullvm@0.52.5
433 windows_aarch64_msvc@0.48.5
434 windows_aarch64_msvc@0.52.5
435 windows_exe_info@0.4.2
436 windows_i686_gnu@0.48.5
437 windows_i686_gnu@0.52.5
438 windows_i686_gnullvm@0.52.5
439 windows_i686_msvc@0.48.5
440 windows_i686_msvc@0.52.5
441 windows_x86_64_gnu@0.48.5
442 windows_x86_64_gnu@0.52.5
443 windows_x86_64_gnullvm@0.48.5
444 windows_x86_64_gnullvm@0.52.5
445 windows_x86_64_msvc@0.48.5
446 windows_x86_64_msvc@0.52.5
457 zerocopy-derive@0.7.32
461 zvariant_derive@4.0.2
465 PLOCALES="en_US zh_CN"
466 inherit cargo desktop gnome2-utils plocale xdg
468 DESCRIPTION="Simple On Screen lyrics Display for linux/unix"
470 https://waylyrics.github.io/waylyrics/waylyrics
471 https://github.com/waylyrics/waylyrics
474 if [[ "${PV}" == *9999* ]]; then
476 EGIT_REPO_URI="https://github.com/waylyrics/waylyrics.git"
479 https://github.com/waylyrics/waylyrics/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
482 KEYWORDS="~amd64 ~loong"
485 LICENSE="MIT CC-BY-4.0"
486 # Dependent crate licenses
488 Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD GPL-3+ ISC MIT
489 MPL-2.0 Unicode-DFS-2016 Unlicense
505 >=virtual/rust-1.73:*
509 export WAYLYRICS_THEME_PRESETS_DIR="/usr/share/${PN}/themes"
510 cargo_src_compile --all-targets --all-features
516 doicon -s scalable "${S}/res/icons/hicolor/scalable/apps/io.github.waylyrics.Waylyrics.svg"
517 domenu "${S}/metainfo/io.github.waylyrics.Waylyrics.desktop"
519 insinto "/usr/share/glib-2.0/schemas"
520 doins "${S}/metainfo/io.github.waylyrics.Waylyrics.gschema.xml"
522 insinto "/usr/share/metainfo"
523 doins "${S}/metainfo/io.github.waylyrics.Waylyrics.metainfo.xml"
525 insinto "/usr/share/${PN}"
528 cd "${S}/locales" || die
530 if [[ -f ${1}/LC_MESSAGES/waylyrics.po ]]; then
531 local file=${1}/LC_MESSAGES/waylyrics.po
532 msgfmt "${file}" -o "${file%.po}.mo" || die
533 insinto /usr/share/locale/${1}/LC_MESSAGES
534 doins "${file%.po}.mo"
537 plocale_for_each_locale install_locale
541 gnome2_schemas_update
546 gnome2_schemas_update