app-editors/zed: add 0.140.5, drop 0.139.3
[gentoo-zh.git] / net-misc / rustdesk / rustdesk-1.2.3.ebuild
blob3a40d113ce3efa0afb31b1f6098c86c2b1452274
1 # Copyright 2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 CRATES="
7         addr2line@0.21.0
8         adler@1.0.2
9         aes@0.8.3
10         ahash@0.7.7
11         ahash@0.8.6
12         aho-corasick@1.1.2
13         allo-isolate@0.1.20
14         alloc-no-stdlib@2.0.4
15         alloc-stdlib@0.2.2
16         allocator-api2@0.2.16
17         alsa-sys@0.3.1
18         alsa@0.7.1
19         android-tzdata@0.1.1
20         android_log-sys@0.3.1
21         android_logger@0.13.3
22         android_system_properties@0.1.5
23         ansi_term@0.12.1
24         anstream@0.6.4
25         anstyle-parse@0.2.2
26         anstyle-query@1.0.0
27         anstyle-wincon@3.0.1
28         anstyle@1.0.4
29         anyhow@1.0.75
30         apple-bindgen@0.2.0
31         apple-sdk@0.4.0
32         apple-sys@0.2.0
33         arboard@3.3.0
34         async-broadcast@0.5.1
35         async-channel@1.9.0
36         async-compression@0.4.5
37         async-executor@1.6.0
38         async-fs@1.6.0
39         async-io@1.13.0
40         async-lock@2.8.0
41         async-process@1.8.1
42         async-recursion@1.0.5
43         async-signal@0.2.4
44         async-task@4.5.0
45         async-trait@0.1.74
46         atk-sys@0.18.0
47         atk@0.18.0
48         atomic-waker@1.1.2
49         atomic@0.5.3
50         atty@0.2.14
51         autocfg@0.1.8
52         autocfg@1.1.0
53         backtrace@0.3.69
54         base32@0.4.0
55         base64@0.21.5
56         base64ct@1.6.0
57         bindgen@0.59.2
58         bindgen@0.63.0
59         bindgen@0.65.1
60         bindgen@0.68.1
61         bit_field@0.10.2
62         bitflags@1.3.2
63         bitflags@2.4.1
64         bitmask-enum@2.2.2
65         bitvec@1.0.1
66         block-buffer@0.10.4
67         block-sys@0.1.0-beta.1
68         block2@0.2.0-alpha.6
69         block@0.1.6
70         blocking@1.4.1
71         brotli-decompressor@2.5.1
72         brotli@3.4.0
73         build-target@0.4.0
74         bumpalo@3.14.0
75         bytecount@0.6.7
76         bytemuck@1.14.0
77         byteorder@1.5.0
78         bytes@1.5.0
79         bzip2-sys@0.1.11+1.0.8
80         bzip2@0.4.4
81         cairo-rs@0.18.5
82         cairo-sys-rs@0.18.2
83         cc@1.0.83
84         cesu8@1.1.0
85         cexpr@0.6.0
86         cfg-expr@0.15.5
87         cfg-if@0.1.10
88         cfg-if@1.0.0
89         chrono@0.4.31
90         cidr-utils@0.5.11
91         cipher@0.4.4
92         clang-sys@1.6.1
93         clap@2.34.0
94         clap@4.4.7
95         clap_builder@4.4.7
96         clap_lex@0.6.0
97         clipboard-win@4.5.0
98         cloudabi@0.0.3
99         cmake@0.1.50
100         cocoa-foundation@0.1.2
101         cocoa@0.24.1
102         cocoa@0.25.0
103         color_quant@1.1.0
104         colorchoice@1.0.0
105         combine@4.6.6
106         concurrent-queue@2.3.0
107         console_error_panic_hook@0.1.7
108         const_fn@0.4.9
109         const_format@0.2.32
110         const_format_proc_macros@0.2.32
111         constant_time_eq@0.1.5
112         constant_time_eq@0.2.6
113         convert_case@0.4.0
114         core-foundation-sys@0.8.4
115         core-foundation@0.9.3
116         core-graphics-types@0.1.2
117         core-graphics@0.22.3
118         core-graphics@0.23.1
119         coreaudio-rs@0.11.3
120         coreaudio-sys@0.2.13
121         cpal@0.15.2
122         cpufeatures@0.2.11
123         crc32fast@1.3.2
124         crossbeam-channel@0.5.8
125         crossbeam-deque@0.8.3
126         crossbeam-epoch@0.9.15
127         crossbeam-queue@0.3.8
128         crossbeam-utils@0.8.16
129         crunchy@0.2.2
130         crypto-common@0.1.6
131         ctrlc@3.4.1
132         dart-sys@4.0.2
133         dashmap@5.5.3
134         dasp@0.11.0
135         dasp_envelope@0.11.0
136         dasp_frame@0.11.0
137         dasp_interpolate@0.11.0
138         dasp_peak@0.11.0
139         dasp_ring_buffer@0.11.0
140         dasp_rms@0.11.0
141         dasp_sample@0.11.0
142         dasp_signal@0.11.0
143         dasp_slice@0.11.0
144         dasp_window@0.11.1
145         dbus-crossroads@0.5.2
146         dbus@0.9.7
147         debug-helper@0.3.13
148         default-net@0.14.1
149         deranged@0.3.9
150         derivative@2.2.0
151         derive-new@0.5.9
152         derive_more@0.99.17
153         digest@0.10.7
154         directories-next@2.0.0
155         dirs-next@2.0.0
156         dirs-sys-next@0.1.2
157         dirs-sys@0.3.7
158         dirs-sys@0.4.1
159         dirs@2.0.2
160         dirs@5.0.1
161         dispatch@0.2.0
162         dlib@0.5.2
163         dlopen2@0.4.1
164         dlopen2_derive@0.2.0
165         dlopen@0.1.8
166         dlopen_derive@0.1.4
167         dlv-list@0.3.0
168         docopt@1.1.1
169         downcast-rs@1.2.0
170         dtoa@0.4.8
171         ed25519@1.5.3
172         either@1.9.0
173         embed-resource@2.4.0
174         encoding_rs@0.8.33
175         enquote@1.1.0
176         enum-map-derive@0.14.0
177         enum-map@2.7.0
178         enumflags2@0.7.8
179         enumflags2_derive@0.7.8
180         env_logger@0.10.0
181         env_logger@0.9.3
182         epoll@4.3.3
183         equivalent@1.0.1
184         errno@0.3.5
185         error-code@2.3.1
186         event-listener@2.5.3
187         event-listener@3.0.0
188         exr@1.71.0
189         fastrand@1.9.0
190         fastrand@2.0.1
191         fdeflate@0.3.0
192         field-offset@0.3.6
193         filetime@0.2.22
194         fixedbitset@0.4.2
195         flate2@1.0.28
196         flexi_logger@0.27.3
197         flume@0.11.0
198         flutter_rust_bridge@1.80.1
199         flutter_rust_bridge_macros@1.82.3
200         fnv@1.0.7
201         fon@0.6.0
202         foreign-types-macros@0.2.3
203         foreign-types-shared@0.1.1
204         foreign-types-shared@0.3.1
205         foreign-types@0.3.2
206         foreign-types@0.5.0
207         form_urlencoded@1.2.0
208         fruitbasket@0.10.0
209         fuchsia-cprng@0.1.1
210         funty@2.0.0
211         fuser@0.13.0
212         futures-channel@0.3.29
213         futures-core@0.3.29
214         futures-executor@0.3.29
215         futures-io@0.3.29
216         futures-lite@1.13.0
217         futures-macro@0.3.29
218         futures-sink@0.3.29
219         futures-task@0.3.29
220         futures-util@0.3.29
221         futures@0.3.29
222         gdk-pixbuf-sys@0.18.0
223         gdk-pixbuf@0.18.5
224         gdk-sys@0.18.0
225         gdk@0.18.0
226         gdkwayland-sys@0.18.0
227         gdkx11-sys@0.18.0
228         generic-array@0.14.7
229         gethostname@0.3.0
230         getrandom@0.2.10
231         gif@0.12.0
232         gimli@0.28.0
233         gio-sys@0.18.1
234         gio@0.18.4
235         git2@0.16.1
236         glib-macros@0.10.1
237         glib-macros@0.18.5
238         glib-sys@0.10.1
239         glib-sys@0.18.1
240         glib@0.10.3
241         glib@0.18.5
242         glob@0.3.1
243         gobject-sys@0.10.0
244         gobject-sys@0.18.0
245         gstreamer-app-sys@0.9.1
246         gstreamer-app@0.16.5
247         gstreamer-base-sys@0.9.1
248         gstreamer-base@0.16.5
249         gstreamer-sys@0.9.1
250         gstreamer-video-sys@0.9.1
251         gstreamer-video@0.16.7
252         gstreamer@0.16.7
253         gtk-sys@0.18.0
254         gtk3-macros@0.18.0
255         gtk@0.18.1
256         h2@0.3.21
257         half@2.2.1
258         hashbrown@0.12.3
259         hashbrown@0.14.2
260         heck@0.3.3
261         heck@0.4.1
262         hermit-abi@0.1.19
263         hermit-abi@0.3.3
264         hex@0.4.3
265         hmac@0.12.1
266         home@0.5.5
267         hound@3.5.1
268         html-escape@0.2.13
269         http-body@0.4.5
270         http@0.2.9
271         httparse@1.8.0
272         httpdate@1.0.3
273         humantime@2.1.0
274         hyper-rustls@0.24.2
275         hyper-tls@0.5.0
276         hyper@0.14.27
277         iana-time-zone-haiku@0.1.2
278         iana-time-zone@0.1.58
279         idna@0.4.0
280         image@0.24.7
281         include_dir@0.7.3
282         include_dir_macros@0.7.3
283         indexmap@1.9.3
284         indexmap@2.0.2
285         inotify-sys@0.1.5
286         inotify@0.10.2
287         inout@0.1.3
288         instant@0.1.12
289         io-lifetimes@1.0.11
290         ipnet@2.9.0
291         is-terminal@0.4.9
292         is_debug@1.0.1
293         itertools@0.9.0
294         itoa@0.3.4
295         itoa@1.0.9
296         jni-sys@0.3.0
297         jni@0.19.0
298         jni@0.20.0
299         jni@0.21.1
300         jobserver@0.1.27
301         jpeg-decoder@0.3.0
302         js-sys@0.3.64
303         kernel32-sys@0.2.2
304         keyboard-types@0.7.0
305         lazy_static@1.4.0
306         lazycell@1.3.0
307         lebe@0.5.2
308         libappindicator-sys@0.9.0
309         libappindicator@0.9.0
310         libc@0.2.150
311         libdbus-sys@0.2.5
312         libgit2-sys@0.14.2+1.5.1
313         libloading@0.7.4
314         libloading@0.8.1
315         libm@0.2.8
316         libpulse-binding@2.28.1
317         libpulse-simple-binding@2.28.1
318         libpulse-simple-sys@1.21.1
319         libpulse-sys@1.21.0
320         libsamplerate-sys@0.1.12
321         libsodium-sys@0.2.7
322         libxdo-sys@0.11.0
323         libxdo@0.6.0
324         libz-sys@1.1.12
325         line-wrap@0.1.1
326         linux-raw-sys@0.3.8
327         linux-raw-sys@0.4.10
328         lock_api@0.4.11
329         log@0.4.20
330         mac_address@1.1.5
331         mach2@0.4.1
332         malloc_buf@0.0.6
333         md5@0.7.0
334         memalloc@0.1.0
335         memchr@2.6.4
336         memoffset@0.6.5
337         memoffset@0.7.1
338         memoffset@0.9.0
339         mime@0.3.17
340         minimal-lexical@0.2.1
341         miniz_oxide@0.7.1
342         mio@0.8.9
343         miow@0.6.0
344         muda@0.11.4
345         muldiv@0.2.1
346         native-tls@0.2.11
347         ndk-context@0.1.1
348         ndk-sys@0.4.1+23.1.7779620
349         ndk@0.7.0
350         netlink-packet-core@0.5.0
351         netlink-packet-route@0.15.0
352         netlink-packet-utils@0.5.2
353         netlink-sys@0.8.5
354         nix@0.23.2
355         nix@0.24.3
356         nix@0.26.4
357         nix@0.27.1
358         nom8@0.2.0
359         nom@7.1.3
360         ntapi@0.4.1
361         nu-ansi-term@0.49.0
362         num-bigint@0.4.4
363         num-complex@0.4.4
364         num-derive@0.3.3
365         num-integer@0.1.45
366         num-rational@0.3.2
367         num-rational@0.4.1
368         num-traits@0.1.43
369         num-traits@0.2.17
370         num_cpus@1.16.0
371         num_enum@0.5.11
372         num_enum_derive@0.5.11
373         num_threads@0.1.6
374         objc-foundation@0.1.1
375         objc-sys@0.2.0-beta.2
376         objc2-encode@2.0.0-pre.2
377         objc2@0.3.0-beta.2
378         objc@0.2.7
379         objc_exception@0.1.2
380         objc_id@0.1.1
381         object@0.32.1
382         oboe-sys@0.5.0
383         oboe@0.5.0
384         once_cell@1.18.0
385         openssl-macros@0.1.1
386         openssl-probe@0.1.5
387         openssl-sys@0.9.98
388         openssl@0.10.62
389         option-ext@0.2.0
390         ordered-multimap@0.4.3
391         ordered-stream@0.2.0
392         os-version@0.2.0
393         os_info@3.7.0
394         os_pipe@1.1.4
395         osascript@0.3.0
396         page_size@0.5.0
397         pam-macros@0.0.3
398         pam-sys@1.0.0-alpha4
399         pango-sys@0.18.0
400         pango@0.18.3
401         parking@2.2.0
402         parking_lot@0.12.1
403         parking_lot_core@0.9.9
404         password-hash@0.4.2
405         paste@1.0.14
406         pbkdf2@0.11.0
407         peeking_take_while@0.1.2
408         percent-encoding@2.3.0
409         petgraph@0.6.4
410         phf@0.7.24
411         phf_codegen@0.7.24
412         phf_generator@0.7.24
413         phf_shared@0.7.24
414         pin-project-internal@1.1.3
415         pin-project-lite@0.2.13
416         pin-project@1.1.3
417         pin-utils@0.1.0
418         piper@0.2.1
419         pkg-config@0.3.27
420         plist@1.5.1
421         png@0.17.10
422         polling@2.8.0
423         powerfmt@0.2.0
424         ppv-lite86@0.2.17
425         pretty-hex@0.2.1
426         prettyplease@0.2.15
427         primal-check@0.3.3
428         proc-macro-crate@0.1.5
429         proc-macro-crate@1.3.1
430         proc-macro-crate@2.0.0
431         proc-macro-error-attr@1.0.4
432         proc-macro-error@1.0.4
433         proc-macro2@0.4.30
434         proc-macro2@1.0.69
435         protobuf-codegen@3.3.0
436         protobuf-parse@3.3.0
437         protobuf-support@3.3.0
438         protobuf@3.3.0
439         qoi@0.4.1
440         qrcode-generator@4.1.9
441         qrcodegen@1.8.0
442         quest@0.3.0
443         quick-xml@0.30.0
444         quinn-proto@0.9.6
445         quinn-udp@0.3.2
446         quinn@0.9.4
447         quote@0.6.13
448         quote@1.0.33
449         radium@0.7.0
450         rand@0.6.5
451         rand@0.8.5
452         rand_chacha@0.1.1
453         rand_chacha@0.3.1
454         rand_core@0.3.1
455         rand_core@0.4.2
456         rand_core@0.6.4
457         rand_hc@0.1.0
458         rand_isaac@0.1.1
459         rand_jitter@0.1.4
460         rand_os@0.1.3
461         rand_pcg@0.1.2
462         rand_xorshift@0.1.1
463         raw-window-handle@0.5.2
464         raw-window-handle@0.6.0
465         rayon-core@1.12.0
466         rayon@1.8.0
467         rdrand@0.4.0
468         realfft@3.3.0
469         redox_syscall@0.2.16
470         redox_syscall@0.3.5
471         redox_syscall@0.4.1
472         redox_users@0.4.3
473         regex-automata@0.4.3
474         regex-syntax@0.8.2
475         regex@1.10.2
476         repng@0.2.2
477         ring@0.16.20
478         ring@0.17.5
479         ringbuf@0.3.3
480         rpassword@2.1.0
481         rpassword@7.2.0
482         rtoolbox@0.0.1
483         rubato@0.12.0
484         runas@1.0.0
485         rust-ini@0.18.0
486         rustc-demangle@0.1.23
487         rustc-hash@1.1.0
488         rustc_version@0.4.0
489         rustfft@6.1.0
490         rustix@0.37.27
491         rustix@0.38.21
492         rustls-native-certs@0.6.3
493         rustls-pemfile@1.0.3
494         rustls-webpki@0.101.7
495         rustls@0.20.9
496         rustls@0.21.10
497         rustversion@1.0.14
498         ryu@1.0.15
499         safemem@0.3.3
500         same-file@1.0.6
501         samplerate@0.2.4
502         schannel@0.1.22
503         scoped-tls@1.0.1
504         scopeguard@1.2.0
505         sct@0.7.1
506         security-framework-sys@2.9.1
507         security-framework@2.9.2
508         semver@1.0.20
509         serde@0.9.15
510         serde@1.0.190
511         serde_derive@1.0.190
512         serde_json@0.9.10
513         serde_json@1.0.107
514         serde_repr@0.1.16
515         serde_spanned@0.6.4
516         serde_urlencoded@0.7.1
517         sha1@0.10.6
518         sha2@0.10.8
519         shadow-rs@0.21.0
520         shared_memory@0.12.4
521         shlex@1.2.0
522         shutdown_hooks@0.1.0
523         signal-hook-registry@1.4.1
524         signature@1.6.4
525         simd-adler32@0.3.7
526         siphasher@0.2.3
527         slab@0.4.9
528         smallvec@1.11.1
529         socket2@0.3.19
530         socket2@0.4.10
531         socket2@0.5.5
532         sodiumoxide@0.2.7
533         spin@0.5.2
534         spin@0.9.8
535         static_assertions@1.1.0
536         str-buf@1.0.6
537         strength_reduce@0.2.4
538         strsim@0.10.0
539         strsim@0.8.0
540         strum@0.18.0
541         strum@0.24.1
542         strum_macros@0.18.0
543         strum_macros@0.24.3
544         subtle@2.5.0
545         syn@0.15.44
546         syn@1.0.109
547         syn@2.0.38
548         sync_wrapper@0.1.2
549         sys-locale@0.3.1
550         system-configuration-sys@0.5.0
551         system-configuration@0.5.1
552         system-deps@1.3.2
553         system-deps@6.1.2
554         system_shutdown@4.0.1
555         tap@1.0.1
556         target-lexicon@0.12.12
557         target_build_utils@0.3.1
558         tauri-winrt-notification@0.1.3
559         tempfile@3.8.1
560         termcolor@1.3.0
561         termios@0.3.3
562         textwrap@0.11.0
563         thiserror-impl@1.0.50
564         thiserror@1.0.50
565         threadpool@1.8.1
566         tiff@0.9.0
567         time-core@0.1.2
568         time-macros@0.2.15
569         time@0.1.45
570         time@0.3.30
571         tinyvec@1.6.0
572         tinyvec_macros@0.1.1
573         tokio-macros@2.2.0
574         tokio-native-tls@0.3.1
575         tokio-rustls@0.24.1
576         tokio-util@0.7.10
577         tokio@1.36.0
578         toml@0.5.11
579         toml@0.6.0
580         toml@0.7.8
581         toml@0.8.6
582         toml_datetime@0.5.1
583         toml_datetime@0.6.5
584         toml_edit@0.18.1
585         toml_edit@0.19.15
586         toml_edit@0.20.7
587         totp-rs@5.4.0
588         tower-service@0.3.2
589         tracing-attributes@0.1.27
590         tracing-core@0.1.32
591         tracing@0.1.40
592         transpose@0.2.2
593         tree_magic_mini@3.0.3
594         try-lock@0.2.4
595         typenum@1.17.0
596         tz-rs@0.6.14
597         tzdb@0.5.7
598         uds_windows@1.0.2
599         uname@0.1.1
600         unicode-bidi@0.3.13
601         unicode-ident@1.0.12
602         unicode-normalization@0.1.22
603         unicode-segmentation@1.10.1
604         unicode-width@0.1.11
605         unicode-xid@0.1.0
606         unicode-xid@0.2.4
607         untrusted@0.7.1
608         untrusted@0.9.0
609         url@2.4.1
610         urlencoding@2.1.3
611         users@0.10.0
612         users@0.11.0
613         utf16string@0.2.0
614         utf8-width@0.1.7
615         utf8parse@0.2.1
616         uuid@1.5.0
617         vcpkg@0.2.15
618         vec_map@0.8.2
619         version-compare@0.0.10
620         version-compare@0.1.1
621         version_check@0.9.4
622         vswhom-sys@0.1.2
623         vswhom@0.1.0
624         waker-fn@1.1.1
625         walkdir@2.4.0
626         want@0.3.1
627         wasi@0.10.0+wasi-snapshot-preview1
628         wasi@0.11.0+wasi-snapshot-preview1
629         wasm-bindgen-backend@0.2.87
630         wasm-bindgen-futures@0.4.37
631         wasm-bindgen-macro-support@0.2.87
632         wasm-bindgen-macro@0.2.87
633         wasm-bindgen-shared@0.2.87
634         wasm-bindgen@0.2.87
635         wayland-backend@0.3.2
636         wayland-client@0.31.1
637         wayland-protocols-wlr@0.2.0
638         wayland-protocols@0.31.0
639         wayland-scanner@0.31.0
640         wayland-sys@0.31.1
641         web-sys@0.3.64
642         webpki-roots@0.25.3
643         webpki@0.22.4
644         weezl@0.1.7
645         which@4.4.2
646         whoami@1.4.1
647         widestring@1.0.2
648         win-sys@0.3.1
649         winapi-build@0.1.1
650         winapi-i686-pc-windows-gnu@0.4.0
651         winapi-util@0.1.6
652         winapi-wsapoll@0.1.1
653         winapi-x86_64-pc-windows-gnu@0.4.0
654         winapi@0.2.8
655         winapi@0.3.9
656         windows-core@0.51.1
657         windows-core@0.52.0
658         windows-implement@0.52.0
659         windows-interface@0.52.0
660         windows-service@0.6.0
661         windows-sys@0.42.0
662         windows-sys@0.45.0
663         windows-sys@0.48.0
664         windows-sys@0.52.0
665         windows-targets@0.42.2
666         windows-targets@0.48.5
667         windows-targets@0.52.0
668         windows-version@0.1.0
669         windows@0.32.0
670         windows@0.34.0
671         windows@0.44.0
672         windows@0.46.0
673         windows@0.48.0
674         windows@0.51.1
675         windows@0.52.0
676         windows_aarch64_gnullvm@0.42.2
677         windows_aarch64_gnullvm@0.48.5
678         windows_aarch64_gnullvm@0.52.0
679         windows_aarch64_msvc@0.32.0
680         windows_aarch64_msvc@0.34.0
681         windows_aarch64_msvc@0.42.2
682         windows_aarch64_msvc@0.48.5
683         windows_aarch64_msvc@0.52.0
684         windows_i686_gnu@0.32.0
685         windows_i686_gnu@0.34.0
686         windows_i686_gnu@0.42.2
687         windows_i686_gnu@0.48.5
688         windows_i686_gnu@0.52.0
689         windows_i686_msvc@0.32.0
690         windows_i686_msvc@0.34.0
691         windows_i686_msvc@0.42.2
692         windows_i686_msvc@0.48.5
693         windows_i686_msvc@0.52.0
694         windows_x86_64_gnu@0.32.0
695         windows_x86_64_gnu@0.34.0
696         windows_x86_64_gnu@0.42.2
697         windows_x86_64_gnu@0.48.5
698         windows_x86_64_gnu@0.52.0
699         windows_x86_64_gnullvm@0.42.2
700         windows_x86_64_gnullvm@0.48.5
701         windows_x86_64_gnullvm@0.52.0
702         windows_x86_64_msvc@0.32.0
703         windows_x86_64_msvc@0.34.0
704         windows_x86_64_msvc@0.42.2
705         windows_x86_64_msvc@0.48.5
706         windows_x86_64_msvc@0.52.0
707         winnow@0.5.17
708         winreg@0.11.0
709         winreg@0.50.0
710         winreg@0.51.0
711         winres@0.1.12
712         wl-clipboard-rs@0.8.0
713         wol-rs@1.0.1
714         wyz@0.5.1
715         x11-dl@2.21.0
716         x11@2.21.0
717         x11rb-protocol@0.12.0
718         x11rb@0.12.0
719         xdg-home@1.0.0
720         zbus@3.14.1
721         zbus_macros@3.14.1
722         zbus_names@2.6.0
723         zerocopy-derive@0.6.5
724         zerocopy-derive@0.7.18
725         zerocopy@0.6.5
726         zerocopy@0.7.18
727         zip@0.6.6
728         zstd-safe@5.0.2+zstd.1.5.2
729         zstd-safe@7.0.0
730         zstd-sys@2.0.9+zstd.1.5.5
731         zstd@0.11.2+zstd.1.5.2
732         zstd@0.13.0
733         zune-inflate@0.2.54
734         zvariant@3.15.0
735         zvariant_derive@3.15.0
736         zvariant_utils@1.0.1
739 declare -A GIT_CRATES=(
740         [amf]='https://github.com/21pages/gpucodec;90800ce41bee33cd898ec36a86c2e32a407e3f02;gpucodec-%commit%/amf'
741         [android-wakelock]='https://github.com/21pages/android-wakelock;d0292e5a367e627c4fa6f1ca6bdfad005dca7d90;android-wakelock-%commit%'
742         [cacao]='https://github.com/clslaid/cacao;05e1536b0b43aaae308ec72c0eed703e875b7b95;cacao-%commit%'
743         [confy]='https://github.com/open-trade/confy;7855cd3c32b1a60b44e5076ee8f6b4131da10350;confy-%commit%'
744         [core-foundation-sys]='https://github.com/madsmtm/core-foundation-rs;7d593d016175755e492a92ef89edca68ac3bd5cd;core-foundation-rs-%commit%/core-foundation-sys'
745         [core-foundation]='https://github.com/madsmtm/core-foundation-rs;7d593d016175755e492a92ef89edca68ac3bd5cd;core-foundation-rs-%commit%/core-foundation'
746         [core-graphics-types]='https://github.com/madsmtm/core-foundation-rs;7d593d016175755e492a92ef89edca68ac3bd5cd;core-foundation-rs-%commit%/core-graphics-types'
747         [core-graphics]='https://github.com/madsmtm/core-foundation-rs;7d593d016175755e492a92ef89edca68ac3bd5cd;core-foundation-rs-%commit%/core-graphics'
748         [evdev]='https://github.com/fufesou/evdev;cec616e37790293d2cd2aa54a96601ed6b1b35a9;evdev-%commit%'
749         [gpu_common]='https://github.com/21pages/gpucodec;90800ce41bee33cd898ec36a86c2e32a407e3f02;gpucodec-%commit%/common'
750         [gpucodec]='https://github.com/21pages/gpucodec;90800ce41bee33cd898ec36a86c2e32a407e3f02;gpucodec-%commit%/codec'
751         [hwcodec]='https://github.com/21pages/hwcodec;da8aec8e8abb6a5506e027484023e6e2ad1f47eb;hwcodec-%commit%'
752         [impersonate_system]='https://github.com/21pages/impersonate-system;2f429010a5a10b1fe5eceb553c6672fd53d20167;impersonate-system-%commit%'
753         [keepawake]='https://github.com/rustdesk-org/keepawake-rs;ad94454a75cf1ff9e95e217dee9dd6a378bf625e;keepawake-rs-%commit%'
754         [machine-uid]='https://github.com/21pages/machine-uid;381ff579c1dc3a6c54db9dfec47c44bcb0246542;machine-uid-%commit%'
755         [magnum-opus]='https://github.com/rustdesk-org/magnum-opus;5cd2bf989c148662fa3a2d9d539a71d71fd1d256;magnum-opus-%commit%'
756         [mouce]='https://github.com/fufesou/mouce;ed83800d532b95d70e39915314f6052aa433e9b9;mouce-%commit%'
757         [nv]='https://github.com/21pages/gpucodec;90800ce41bee33cd898ec36a86c2e32a407e3f02;gpucodec-%commit%/nv'
758         [pam]='https://github.com/fufesou/pam;10da2cbbabe32cbc9de22a66abe44738e7ec0ea0;pam-%commit%'
759         [parity-tokio-ipc]='https://github.com/rustdesk-org/parity-tokio-ipc;f2d1fcf8fb002335d9a62bec308559d40698694d;parity-tokio-ipc-%commit%'
760         [rdev]='https://github.com/fufesou/rdev;b3434caee84c92412b45a2f655a15ac5dad33488;rdev-%commit%'
761         [reqwest]='https://github.com/rustdesk-org/reqwest;9cb758c9fb2f4edc62eb790acfd45a6a3da21ed3;reqwest-%commit%'
762         [rust-pulsectl]='https://github.com/open-trade/pulsectl;5e68f4c2b7c644fa321984688602d71e8ad0bba3;pulsectl-%commit%'
763         [sciter-rs]='https://github.com/open-trade/rust-sciter;fab913b7c2e779b05c249b0c5de5a08759b2c15d;rust-sciter-%commit%'
764         [sysinfo]='https://github.com/rustdesk-org/sysinfo;f45dcc6510d48c3a1401c5a33eedccc8899f67b2;sysinfo-%commit%'
765         [tao-macros]='https://github.com/rustdesk-org/tao;1a813dc8788735ff0ad427ffa71394aa02d16709;tao-%commit%/tao-macros'
766         [tao]='https://github.com/rustdesk-org/tao;1a813dc8788735ff0ad427ffa71394aa02d16709;tao-%commit%'
767         [tfc]='https://github.com/fufesou/The-Fat-Controller;9dd86151525fd010dc93f6bc9b6aedd1a75cc342;The-Fat-Controller-%commit%'
768         [tokio-socks]='https://github.com/open-trade/tokio-socks;14a5c2564fa20a2765ea53d03c573ee2b7e20421;tokio-socks-%commit%'
769         [tray-icon]='https://github.com/tauri-apps/tray-icon;b8dbd42c6f94a29f34b0a0daa619486277185512;tray-icon-%commit%'
770         [vpl]='https://github.com/21pages/gpucodec;90800ce41bee33cd898ec36a86c2e32a407e3f02;gpucodec-%commit%/vpl'
771         [wallpaper]='https://github.com/21pages/wallpaper.rs;ce4a0cd3f58327c7cc44d15a63706fb0c022bacf;wallpaper.rs-%commit%'
772         [webm-sys]='https://github.com/21pages/rust-webm;d2c4d3ac133c7b0e4c0f656da710b48391981e64;rust-webm-%commit%/src/sys'
773         [webm]='https://github.com/21pages/rust-webm;d2c4d3ac133c7b0e4c0f656da710b48391981e64;rust-webm-%commit%'
774         [x11-clipboard]='https://github.com/clslaid/x11-clipboard;5fc2e73bc01ada3681159b34cf3ea8f0d14cd904;x11-clipboard-%commit%'
775         [x11]='https://github.com/bjornsnoen/x11-rs;c2e9bfaa7b196938f8700245564d8ac5d447786a;x11-rs-%commit%/x11'
778 inherit cargo systemd desktop xdg
780 DESCRIPTION="Open source virtual / remote desktop infrastructure for everyone"
781 HOMEPAGE="https://rustdesk.com/"
782 EGIT_COMMIT="914da2b86f73a314027833b1940784d657826503"
783 _THIDR_PARTY_COMMIT="20ee6a80eab87a1cec585d2a4365b14be879de49"
784 _SCRITER_COMMIT="0298f1b34e9a0ff1dffb889d82c506a5da8bfb1e"
785 _WEBM_PV="1.0.0.31"
786 SRC_URI="
787         https://github.com/rustdesk/rustdesk/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz
788         https://github.com/st0nie/gentoo-deps/releases/download/vcpkg/vcpkg-20240222.tar.gz
789         https://github.com/c-smile/sciter-sdk/raw/${_SCRITER_COMMIT}/bin.lnx/x64/libsciter-gtk.so -> ${P}-libsciter-gtk.so
790         https://github.com/webmproject/libwebm/archive/refs/tags/libwebm-${_WEBM_PV}.tar.gz
791         ${CARGO_CRATE_URIS}
794 LICENSE="AGPL-3"
795 SLOT="0"
796 RESTRICT="mirror"
797 KEYWORDS="~amd64"
799 IUSE="wayland +hwaccel"
801 RDEPEND="
802         media-libs/alsa-lib
803         x11-libs/gtk+:3
804         x11-libs/libxcb
805         x11-libs/libXfixes
806         media-libs/libpulse
807         x11-misc/xdotool
808         media-libs/libva
809         wayland? ( media-video/pipewire[gstreamer] )
810         hwaccel? ( x11-libs/libvdpau )
812 BDEPEND="
813         dev-lang/nasm
814         dev-lang/yasm
815         media-libs/alsa-lib
816         media-libs/libpulse
817         dev-build/cmake
818         sys-devel/clang
819         dev-build/ninja
820         media-libs/gstreamer
821         media-libs/gst-plugins-base
822         >=virtual/rust-1.75.0
824 QA_PRESTRIPPED="
825         /usr/share/${PN}/${PN}
826         /usr/share/${PN}/libsciter-gtk.so
829 S="${WORKDIR}/rustdesk-${EGIT_COMMIT}"
831 src_prepare() {
832         default
833         cd ../rust-webm-*/src/sys || die
834         rm -rf libwebm/ || die
835         ln -s ${WORKDIR}/libwebm-libwebm-*/ libwebm || die
838 src_configure() {
839         if use hwaccel ;then
840                 local myfeatures=(hwcodec)
841         fi
843         cargo_src_configure
846 src_compile() {
847         VCPKG_ROOT="$WORKDIR"/vcpkg cargo_src_compile
850 src_install() {
851         local rustdesk_dir="/usr/share/${PN}"
853         exeinto "${rustdesk_dir}"
854         insinto "${rustdesk_dir}"
855         doexe target/release/rustdesk
856         newins "${DISTDIR}/${P}-libsciter-gtk.so" libsciter-gtk.so
857         rm src/ui/*.rs || die
858         newbin "${FILESDIR}/rustdesk.sh" rustdesk
859         insinto "${rustdesk_dir}/src"
860         doins -r src/ui
862         newicon -s 32 $(realpath res/32x32.png || die) rustdesk.png
863         newicon -s 128 $(realpath res/128x128.png || die) rustdesk.png
864         newicon -s 256 $(realpath res/128x128@2x.png || die) rustdesk.png
866         domenu "${FILESDIR}"/rustdesk{,-link}.desktop
867         systemd_dounit "${FILESDIR}"/rustdesk.service
869         einstalldocs