app-editors/zed: add 0.140.5, drop 0.139.3
[gentoo-zh.git] / net-proxy / clash-rs / clash-rs-0.1.15.ebuild
blob73d1adb01bc3cbfbf575e23ea34bc8714c927e4c
1 # Copyright 2023-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 # Autogenerated by pycargoebuild 0.13.2
6 EAPI=8
8 CRATES="
9         addr2line@0.21.0
10         adler@1.0.2
11         aead@0.5.2
12         aes-gcm@0.10.3
13         aes@0.8.4
14         ahash@0.8.7
15         aho-corasick@1.1.2
16         alloc-no-stdlib@2.0.4
17         alloc-stdlib@0.2.2
18         allocator-api2@0.2.16
19         amplify@4.5.0
20         amplify_derive@4.0.0
21         amplify_num@0.5.1
22         amplify_syn@2.0.1
23         android-tzdata@0.1.1
24         android_system_properties@0.1.5
25         anes@0.1.6
26         ansi_term@0.12.1
27         anstream@0.6.11
28         anstyle-parse@0.2.3
29         anstyle-query@1.0.2
30         anstyle-wincon@3.0.2
31         anstyle@1.0.4
32         anyhow@1.0.80
33         arc-swap@1.6.0
34         arrayref@0.3.7
35         arrayvec@0.7.4
36         arti-client@0.14.0
37         ascii@1.1.0
38         async-compression@0.4.6
39         async-recursion@1.0.5
40         async-stream-impl@0.3.5
41         async-stream@0.3.5
42         async-trait@0.1.77
43         async_executors@0.7.0
44         asynchronous-codec@0.7.0
45         atomic@0.5.3
46         atty@0.2.14
47         autocfg@1.1.0
48         axum-core@0.3.4
49         axum-core@0.4.3
50         axum-macros@0.4.1
51         axum@0.6.20
52         axum@0.7.4
53         backtrace@0.3.69
54         base16ct@0.2.0
55         base64@0.13.1
56         base64@0.21.7
57         base64@0.22.0
58         base64ct@1.6.0
59         bindgen@0.59.2
60         bindgen@0.68.1
61         bindgen@0.69.2
62         bitflags@1.3.2
63         bitflags@2.4.2
64         bitvec@1.0.1
65         blake2@0.10.6
66         blake3@1.5.0
67         blanket@0.3.0
68         block-buffer@0.10.4
69         boring-sys@4.5.0
70         boring@4.5.0
71         bounded-vec-deque@0.1.1
72         brotli-decompressor@2.5.1
73         brotli@3.4.0
74         bumpalo@3.14.0
75         by_address@1.1.0
76         byte_string@1.0.0
77         byteorder@1.5.0
78         bytes@1.5.0
79         c2rust-bitfields-derive@0.18.0
80         c2rust-bitfields@0.18.0
81         caret@0.4.4
82         cast@0.3.0
83         cc@1.0.83
84         cexpr@0.6.0
85         cfb-mode@0.8.2
86         cfg-if@1.0.0
87         chacha20@0.9.1
88         chacha20poly1305@0.10.1
89         chrono@0.4.35
90         ciborium-io@0.2.1
91         ciborium-ll@0.2.1
92         ciborium@0.2.1
93         cipher@0.4.4
94         clang-sys@1.7.0
95         clap@2.34.0
96         clap@4.5.2
97         clap_builder@4.5.2
98         clap_derive@4.5.0
99         clap_lex@0.7.0
100         cmake@0.1.50
101         coarsetime@0.1.33
102         colorchoice@1.0.0
103         concurrent-queue@2.4.0
104         config@0.13.4
105         console-api@0.6.0
106         console-subscriber@0.2.0
107         const-oid@0.9.6
108         constant_time_eq@0.3.0
109         convert_case@0.4.0
110         core-foundation-sys@0.8.6
111         core-foundation@0.9.4
112         cpufeatures@0.2.12
113         crc32fast@1.4.0
114         criterion-plot@0.5.0
115         criterion@0.5.1
116         crossbeam-channel@0.5.11
117         crossbeam-deque@0.8.5
118         crossbeam-epoch@0.9.18
119         crossbeam-queue@0.3.11
120         crossbeam-utils@0.8.19
121         crossbeam@0.8.4
122         crypto-bigint@0.5.5
123         crypto-common@0.1.6
124         ctor@0.2.7
125         ctr@0.9.2
126         curve25519-dalek-derive@0.1.1
127         curve25519-dalek@4.1.1
128         darling@0.14.4
129         darling@0.20.3
130         darling_core@0.14.4
131         darling_core@0.20.3
132         darling_macro@0.14.4
133         darling_macro@0.20.3
134         data-encoding@2.5.0
135         defmt-macros@0.3.6
136         defmt-parser@0.3.3
137         defmt@0.3.5
138         der@0.7.8
139         deranged@0.3.11
140         derive-adhoc-macros@0.7.3
141         derive-adhoc-macros@0.8.1
142         derive-adhoc@0.7.3
143         derive-adhoc@0.8.1
144         derive_builder_core_fork_arti@0.11.2
145         derive_builder_fork_arti@0.11.2
146         derive_builder_macro_fork_arti@0.11.2
147         derive_more@0.99.17
148         dhcproto-macros@0.1.0
149         dhcproto@0.11.0
150         digest@0.10.7
151         directories@5.0.1
152         dirs-sys@0.4.1
153         dirs@5.0.1
154         displaydoc@0.2.4
155         doc-comment@0.3.3
156         downcast-rs@1.2.0
157         downcast@0.11.0
158         dyn-clone@1.0.16
159         ecdsa@0.16.9
160         ed25519-dalek@2.1.0
161         ed25519@2.2.3
162         educe@0.4.23
163         either@1.9.0
164         elliptic-curve@0.13.8
165         endian-type@0.1.2
166         enum-as-inner@0.5.1
167         enum-as-inner@0.6.0
168         enum-ordinalize@3.1.15
169         env_logger@0.9.3
170         equivalent@1.0.1
171         erased-serde@0.4.3
172         errno@0.3.8
173         event-listener@4.0.3
174         fallible-iterator@0.3.0
175         fallible-streaming-iterator@0.1.9
176         fastrand@2.0.1
177         ff@0.13.0
178         fiat-crypto@0.2.5
179         filetime@0.2.23
180         flate2@1.0.28
181         fluid-let@1.0.0
182         fnv@1.0.7
183         foreign-types-macros@0.2.3
184         foreign-types-shared@0.3.1
185         foreign-types@0.5.0
186         form_urlencoded@1.2.1
187         fragile@2.0.0
188         fs-mistrust@0.7.7
189         fs_extra@1.3.0
190         fsevent-sys@4.1.0
191         fslock@0.2.1
192         funty@2.0.0
193         futures-channel@0.3.30
194         futures-core@0.3.30
195         futures-executor@0.3.30
196         futures-io@0.3.30
197         futures-macro@0.3.30
198         futures-rustls@0.25.1
199         futures-sink@0.3.30
200         futures-task@0.3.30
201         futures-util@0.3.30
202         futures@0.3.30
203         fxhash@0.2.1
204         generic-array@0.14.7
205         getrandom@0.2.12
206         ghash@0.5.0
207         gimli@0.28.1
208         glob-match@0.2.1
209         glob@0.3.1
210         group@0.13.0
211         h2@0.3.24
212         h2@0.4.2
213         half@1.8.2
214         hash32@0.3.1
215         hashbrown@0.12.3
216         hashbrown@0.14.3
217         hashlink@0.8.4
218         hdrhistogram@7.5.4
219         headers-core@0.2.0
220         headers@0.3.9
221         heapless@0.8.0
222         heck@0.4.1
223         hermit-abi@0.1.19
224         hermit-abi@0.3.4
225         hex@0.4.3
226         hickory-client@0.24.0
227         hickory-proto@0.24.0
228         hickory-resolver@0.24.0
229         hickory-server@0.24.0
230         hkdf@0.12.4
231         hmac@0.12.1
232         home@0.5.9
233         hostname-validator@1.1.1
234         hostname@0.3.1
235         http-body-util@0.1.0
236         http-body@0.4.6
237         http-body@1.0.0
238         http-range-header@0.4.0
239         http@0.2.11
240         http@1.1.0
241         httparse@1.8.0
242         httpdate@1.0.3
243         humantime-serde@1.1.1
244         humantime@2.1.0
245         hyper-rustls@0.24.2
246         hyper-timeout@0.4.1
247         hyper-util@0.1.2
248         hyper@0.14.28
249         hyper@1.1.0
250         iana-time-zone-haiku@0.1.2
251         iana-time-zone@0.1.59
252         ident_case@1.0.1
253         idna@0.2.3
254         idna@0.4.0
255         idna@0.5.0
256         indexmap@1.9.3
257         indexmap@2.2.1
258         inotify-sys@0.1.5
259         inotify@0.9.6
260         inout@0.1.3
261         instant@0.1.12
262         integer-encoding@3.0.4
263         inventory@0.3.14
264         ioctl-sys@0.8.0
265         ip_network@0.4.1
266         ip_network_table-deps-treebitmap@0.5.0
267         ip_network_table@0.2.0
268         ipconfig@0.3.2
269         ipnet@2.9.0
270         ipnetwork@0.20.0
271         is-terminal@0.4.10
272         itertools@0.10.5
273         itertools@0.11.0
274         itertools@0.12.0
275         itoa@1.0.10
276         jobserver@0.1.27
277         js-sys@0.3.67
278         keccak@0.1.5
279         kqueue-sys@1.0.4
280         kqueue@1.0.8
281         lazy_static@1.4.0
282         lazycell@1.3.0
283         libc@0.2.153
284         libloading@0.8.1
285         libm@0.2.8
286         libredox@0.0.1
287         libsqlite3-sys@0.27.0
288         linked-hash-map@0.5.6
289         linux-raw-sys@0.4.13
290         lock_api@0.4.11
291         log@0.4.20
292         lru-cache@0.1.2
293         lru_time_cache@0.11.11
294         lzma-sys@0.1.20
295         mach@0.3.2
296         managed@0.8.0
297         match_cfg@0.1.0
298         matchers@0.1.0
299         matches@0.1.10
300         matchit@0.7.3
301         maxminddb@0.24.0
302         md-5@0.10.6
303         memchr@2.7.1
304         memmap2@0.9.3
305         merlin@3.0.0
306         mime@0.3.17
307         mime_guess@2.0.4
308         minimal-lexical@0.2.1
309         miniz_oxide@0.7.1
310         mio@0.8.11
311         mockall@0.12.1
312         mockall_derive@0.12.1
313         murmur3@0.5.2
314         network-interface@1.1.1
315         nibble_vec@0.1.0
316         nix@0.25.1
317         nom@7.1.3
318         notify@6.1.1
319         nu-ansi-term@0.46.0
320         num-bigint-dig@0.8.4
321         num-bigint@0.4.4
322         num-integer@0.1.45
323         num-iter@0.1.43
324         num-traits@0.2.17
325         num_cpus@1.16.0
326         num_enum@0.7.2
327         num_enum_derive@0.7.2
328         object@0.32.2
329         once_cell@1.19.0
330         oorandom@11.1.3
331         opaque-debug@0.3.0
332         openssl-probe@0.1.5
333         opentelemetry-http@0.11.0
334         opentelemetry-jaeger-propagator@0.1.0
335         opentelemetry-jaeger@0.21.0
336         opentelemetry-otlp@0.15.0
337         opentelemetry-proto@0.5.0
338         opentelemetry-semantic-conventions@0.14.0
339         opentelemetry@0.22.0
340         opentelemetry_sdk@0.22.1
341         option-ext@0.2.0
342         ordered-float@2.10.1
343         ordered-float@4.2.0
344         overload@0.1.1
345         p256@0.13.2
346         p384@0.13.0
347         p521@0.13.3
348         parking@2.2.0
349         parking_lot@0.11.2
350         parking_lot@0.12.1
351         parking_lot_core@0.8.6
352         parking_lot_core@0.9.9
353         paste@1.0.14
354         pathdiff@0.2.1
355         peeking_take_while@0.1.2
356         pem-rfc7468@0.7.0
357         percent-encoding@2.3.1
358         phf@0.11.2
359         phf_generator@0.11.2
360         phf_macros@0.11.2
361         phf_shared@0.11.2
362         pin-project-internal@1.1.3
363         pin-project-lite@0.2.13
364         pin-project@1.1.3
365         pin-utils@0.1.0
366         pkcs1@0.7.5
367         pkcs8@0.10.2
368         pkg-config@0.3.29
369         platforms@3.3.0
370         plotters-backend@0.3.5
371         plotters-svg@0.3.5
372         plotters@0.3.5
373         poly1305@0.8.0
374         polyval@0.6.1
375         postage@0.5.0
376         powerfmt@0.2.0
377         ppv-lite86@0.2.17
378         predicates-core@1.0.6
379         predicates-tree@1.0.9
380         predicates@3.1.0
381         prettyplease@0.2.16
382         primeorder@0.13.6
383         priority-queue@1.3.2
384         proc-macro-crate@1.3.1
385         proc-macro-crate@2.0.0
386         proc-macro-crate@3.1.0
387         proc-macro-error-attr@1.0.4
388         proc-macro-error@1.0.4
389         proc-macro2@1.0.76
390         prost-derive@0.12.3
391         prost-types@0.12.3
392         prost@0.12.3
393         public-suffix@0.1.1
394         pwd-grp@0.1.1
395         quanta@0.9.3
396         quick-error@1.2.3
397         quote@1.0.35
398         radium@0.7.0
399         radix_trie@0.2.1
400         rand@0.8.5
401         rand_chacha@0.3.1
402         rand_core@0.6.4
403         raw-cpuid@10.7.0
404         rayon-core@1.12.1
405         rayon@1.8.1
406         redox_syscall@0.2.16
407         redox_syscall@0.4.1
408         redox_users@0.4.4
409         regex-automata@0.1.10
410         regex-automata@0.4.4
411         regex-syntax@0.6.29
412         regex-syntax@0.8.2
413         regex@1.10.3
414         resolv-conf@0.7.0
415         retry-error@0.5.1
416         rfc6979@0.4.0
417         ring-compat@0.8.0
418         ring@0.16.20
419         ring@0.17.7
420         rsa@0.9.6
421         rusqlite@0.30.0
422         rustc-demangle@0.1.23
423         rustc-hash@1.1.0
424         rustc_version@0.4.0
425         rustix@0.38.31
426         rustls-native-certs@0.6.3
427         rustls-pemfile@1.0.4
428         rustls-pki-types@1.2.0
429         rustls-webpki@0.101.7
430         rustls-webpki@0.102.2
431         rustls@0.21.10
432         rustls@0.22.2
433         rustversion@1.0.14
434         ryu@1.0.16
435         safelog@0.3.4
436         same-file@1.0.6
437         sanitize-filename@0.5.0
438         schannel@0.1.23
439         scopeguard@1.2.0
440         sct@0.7.1
441         sec1@0.7.3
442         security-framework-sys@2.9.1
443         security-framework@2.9.2
444         semver@1.0.21
445         sendfd@0.4.3
446         serde-value@0.7.0
447         serde@1.0.197
448         serde_derive@1.0.197
449         serde_ignored@0.1.10
450         serde_json@1.0.114
451         serde_path_to_error@0.1.15
452         serde_spanned@0.6.5
453         serde_urlencoded@0.7.1
454         serde_with@3.4.0
455         serde_with_macros@3.4.0
456         serde_yaml@0.9.32
457         sha1@0.10.6
458         sha2@0.10.8
459         sha3@0.10.8
460         shadowsocks-crypto@0.5.4
461         shadowsocks@1.18.1
462         sharded-slab@0.1.7
463         shellexpand@3.1.0
464         shlex@1.3.0
465         signal-hook-registry@1.4.1
466         signature@1.6.4
467         signature@2.2.0
468         simple_asn1@0.6.2
469         siphasher@0.3.11
470         slab@0.4.9
471         slotmap@1.0.7
472         smallvec@1.13.1
473         smoltcp@0.11.0
474         socket2@0.5.6
475         spin@0.5.2
476         spin@0.9.8
477         spki@0.7.3
478         ssh-cipher@0.2.0
479         ssh-encoding@0.2.0
480         ssh-key@0.6.4
481         stable_deref_trait@1.2.0
482         static_assertions@1.1.0
483         strsim@0.10.0
484         strsim@0.11.0
485         strsim@0.8.0
486         strum@0.25.0
487         strum@0.26.1
488         strum_macros@0.25.3
489         strum_macros@0.26.1
490         subtle@2.5.0
491         syn@1.0.109
492         syn@2.0.48
493         sync_wrapper@0.1.2
494         tap@1.0.1
495         tempfile@3.10.1
496         termcolor@1.4.1
497         termtree@0.4.1
498         textwrap@0.11.0
499         thiserror-impl@1.0.57
500         thiserror@1.0.57
501         thread_local@1.1.7
502         threadpool@1.8.1
503         thrift@0.17.0
504         time-core@0.1.2
505         time-macros@0.2.16
506         time@0.3.31
507         tinystr@0.7.5
508         tinytemplate@1.2.1
509         tinyvec@1.6.0
510         tinyvec_macros@0.1.1
511         tokio-io-timeout@1.2.0
512         tokio-macros@2.2.0
513         tokio-rustls@0.24.1
514         tokio-stream@0.1.14
515         tokio-test@0.4.3
516         tokio-tfo@0.2.2
517         tokio-tungstenite@0.21.0
518         tokio-util@0.7.10
519         tokio@1.36.0
520         toml@0.5.11
521         toml@0.8.8
522         toml_datetime@0.6.5
523         toml_edit@0.19.15
524         toml_edit@0.20.7
525         toml_edit@0.21.0
526         tonic@0.10.2
527         tonic@0.11.0
528         tor-async-utils@0.1.5
529         tor-basic-utils@0.8.0
530         tor-bytes@0.10.0
531         tor-cell@0.16.0
532         tor-cert@0.10.0
533         tor-chanmgr@0.14.0
534         tor-checkable@0.7.0
535         tor-circmgr@0.15.0
536         tor-config@0.10.0
537         tor-consdiff@0.7.0
538         tor-dirclient@0.13.0
539         tor-dirmgr@0.15.0
540         tor-error@0.6.0
541         tor-guardmgr@0.14.0
542         tor-hsclient@0.9.0
543         tor-hscrypto@0.6.0
544         tor-keymgr@0.7.0
545         tor-linkspec@0.11.0
546         tor-llcrypto@0.7.0
547         tor-log-ratelim@0.3.0
548         tor-netdir@0.12.0
549         tor-netdoc@0.12.0
550         tor-persist@0.10.0
551         tor-proto@0.16.0
552         tor-protover@0.6.0
553         tor-rtcompat@0.10.0
554         tor-rtmock@0.13.0
555         tor-socksproto@0.10.0
556         tor-units@0.6.4
557         tower-http@0.5.2
558         tower-layer@0.3.2
559         tower-service@0.3.2
560         tower@0.4.13
561         tracing-appender@0.2.3
562         tracing-attributes@0.1.27
563         tracing-core@0.1.32
564         tracing-log@0.2.0
565         tracing-opentelemetry@0.23.0
566         tracing-oslog@0.1.2
567         tracing-subscriber@0.3.18
568         tracing-test-macro@0.2.4
569         tracing-test@0.2.4
570         tracing-timing@0.6.0
571         tracing@0.1.40
572         trust-dns-proto@0.22.0
573         try-lock@0.2.5
574         tungstenite@0.21.0
575         typed-index-collections@3.1.0
576         typenum@1.17.0
577         unicase@2.7.0
578         unicode-bidi@0.3.15
579         unicode-ident@1.0.12
580         unicode-normalization@0.1.22
581         unicode-width@0.1.11
582         universal-hash@0.5.1
583         unsafe-libyaml@0.2.10
584         untrusted@0.7.1
585         untrusted@0.9.0
586         url@2.5.0
587         urlencoding@2.1.3
588         utf-8@0.7.6
589         utf8parse@0.2.1
590         uuid-macro-internal@1.7.0
591         uuid@1.7.0
592         valuable@0.1.0
593         vcpkg@0.2.15
594         vec_map@0.8.2
595         version_check@0.9.4
596         visibility@0.1.0
597         void@1.0.2
598         walkdir@2.4.0
599         want@0.3.1
600         wasi@0.10.2+wasi-snapshot-preview1
601         wasi@0.11.0+wasi-snapshot-preview1
602         wasm-bindgen-backend@0.2.90
603         wasm-bindgen-macro-support@0.2.90
604         wasm-bindgen-macro@0.2.90
605         wasm-bindgen-shared@0.2.90
606         wasm-bindgen@0.2.90
607         weak-table@0.3.2
608         web-sys@0.3.67
609         web-time@1.1.0
610         webpki-roots@0.25.3
611         which@4.4.2
612         widestring@1.0.2
613         winapi-i686-pc-windows-gnu@0.4.0
614         winapi-util@0.1.6
615         winapi-x86_64-pc-windows-gnu@0.4.0
616         winapi@0.3.9
617         windows-core@0.51.1
618         windows-core@0.52.0
619         windows-sys@0.48.0
620         windows-sys@0.52.0
621         windows-targets@0.48.5
622         windows-targets@0.52.0
623         windows@0.51.1
624         windows_aarch64_gnullvm@0.48.5
625         windows_aarch64_gnullvm@0.52.0
626         windows_aarch64_msvc@0.48.5
627         windows_aarch64_msvc@0.52.0
628         windows_i686_gnu@0.48.5
629         windows_i686_gnu@0.52.0
630         windows_i686_msvc@0.48.5
631         windows_i686_msvc@0.52.0
632         windows_x86_64_gnu@0.48.5
633         windows_x86_64_gnu@0.52.0
634         windows_x86_64_gnullvm@0.48.5
635         windows_x86_64_gnullvm@0.52.0
636         windows_x86_64_msvc@0.48.5
637         windows_x86_64_msvc@0.52.0
638         winnow@0.5.34
639         winreg@0.50.0
640         wintun@0.3.2
641         wyz@0.5.1
642         x25519-dalek@2.0.0
643         x509-signature@0.5.0
644         xz2@0.1.7
645         zerocopy-derive@0.7.32
646         zerocopy@0.7.32
647         zeroize@1.7.0
648         zeroize_derive@1.4.2
649         zstd-safe@7.0.0
650         zstd-sys@2.0.9+zstd.1.5.5
651         zstd@0.13.0
654 declare -A GIT_CRATES=(
655         [boringtun]='https://github.com/cloudflare/boringtun;f672bb6c1e1e371240a8d151f15854687eb740bb;boringtun-%commit%/boringtun'
656         [netstack-lwip]='https://github.com/Watfaq/netstack-lwip;2817bf82740e04bbee6b7bf1165f55657a6ed163;netstack-lwip-%commit%'
657         [tun]='https://github.com/Watfaq/rust-tun;8f7568190f1200d3e272ca534baf8d1578147e18;rust-tun-%commit%'
660 inherit cargo systemd
662 DESCRIPTION="Custom protocol, rule based network proxy"
663 HOMEPAGE="
664         https://watfaq.gitbook.io/clashrs-user-manual/
665         https://github.com/Watfaq/clash-rs/
667 SRC_URI="
668         https://github.com/Watfaq/clash-rs/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
669         ${CARGO_CRATE_URIS}
672 LICENSE="Apache-2.0"
673 # Dependent crate licenses
674 LICENSE+="
675         0BSD Apache-2.0 BSD-2 BSD CC0-1.0 ISC MIT MPL-2.0 Unicode-DFS-2016
676         Unlicense WTFPL-2 ZLIB
678 SLOT="0"
679 KEYWORDS="~amd64"
680 IUSE="doc +lto"
681 REQUIRED_UES="debug? ( !lto )"
683 BDEPEND="
684         sys-devel/llvm:*
685         dev-build/cmake
688 src_compile() {
689         if use !debug; then
690                 # let portage do the strip
691                 export CARGO_PROFILE_RELEASE_STRIP=false
692                 if use !lto; then
693                         export CARGO_PROFILE_RELEASE_LTO=false
694                 fi
695         fi
696         cargo_src_compile
699 src_install() {
700         insinto "/etc/clash-rs"
701         doins "${FILESDIR}/config.example.yaml"
702         systemd_dounit "${FILESDIR}/clash-rs.service"
704         newbin target/$(usex debug "debug" "release")/clash clash-rs
705         use doc && dodoc -r ./docs