app-editors/zed: add 0.140.5, drop 0.139.3
[gentoo-zh.git] / x11-libs / glbinding / glbinding-3.3.0.ebuild
blob8304cd7dd15a9697efb7b6e7c97014b7734b0f83
1 # Copyright 2022 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 DESCRIPTION="A C++ binding for the OpenGL API"
7 HOMEPAGE="https://glbinding.org/"
8 SRC_URI="https://github.com/cginternals/glbinding/archive/refs/tags/v${PV}.tar.gz"
10 IUSE="lto"
12 inherit cmake-multilib
14 RESTRICT="mirror"
16 LICENSE="LGPL-2"
17 SLOT="0"
18 KEYWORDS="x86 amd64 arm arm64"
20 PATCHES=(
21         ${FILESDIR}/glbinding-fix-install.patch
24 src_configure(){
25         mycmakeargs=(
26                 -DOPTION_BUILD_TOOLS=OFF
27                 -DOPTION_BUILD_EXAMPLES=OFF
28                 -DINSTALL_LIB=$(get_libdir)
29                 -DINSTALL_SHARED=$(get_libdir)
30                 -DOPTION_BUILD_WITH_LTO=$(usex lto ON OFF)
31         )
33         cmake-multilib_src_configure
36 src_install(){
37         cmake-multilib_src_install
38         # remove conflict files with libglvnd
39         rm ${D}/usr/include/KHR/khrplatform.h