1 # Copyright 2022 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 DESCRIPTION="A C++ binding for the OpenGL API"
7 HOMEPAGE="https://glbinding.org/"
8 SRC_URI="https://github.com/cginternals/glbinding/archive/refs/tags/v${PV}.tar.gz"
12 inherit cmake-multilib
18 KEYWORDS="x86 amd64 arm arm64"
21 ${FILESDIR}/glbinding-fix-install.patch
26 -DOPTION_BUILD_TOOLS=OFF
27 -DOPTION_BUILD_EXAMPLES=OFF
28 -DINSTALL_LIB=$(get_libdir)
29 -DINSTALL_SHARED=$(get_libdir)
30 -DOPTION_BUILD_WITH_LTO=$(usex lto ON OFF)
33 cmake-multilib_src_configure
37 cmake-multilib_src_install
38 # remove conflict files with libglvnd
39 rm ${D}/usr/include/KHR/khrplatform.h