googlecode.eclass: clean unused eclass
[gentoo-zh.git] / net-wireless / linux-wifi-hotspot / linux-wifi-hotspot-9999.ebuild
blob0dafc9336fb3eb7d30bdd0ced54058098611b2b5
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
5 LICENSE=BSD
6 DESCRIPTION="Linux Wifi Hotspot"
7 HOMEPAGE="https://github.com/lakinduakash/linux-wifi-hotspot"
8 SLOT="0"
9 # inherit toolchain-funcs eutils
11 DEPEND="media-gfx/qrencode
12         net-wireless/iw
13             net-wireless/hostapd
14        "
15 RDEPEND="${DEPEND}"
16 if [ "$PV" == "9999" ]; then
17     inherit git-r3
18         EGIT_REPO_URI="https://github.com/lakinduakash/linux-wifi-hotspot.git"
19         KEYWORDS=""
20 else
21         SRC_URI="https://github.com/lakinduakash/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
22         KEYWORDS="~amd64 ~x86"
25 src_install() {
26         emake DESTDIR="${D}" install