app-i18n/fcitx-chewing: add 5.1.4, drop 5.1.2
[gentoo-zh.git] / dev-util / pacstrap / pacstrap-28.ebuild
blob72e532f09230d484496d52ccb49653ae2172b155
1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit bash-completion-r1
8 DESCRIPTION="Pacstrap - install packages to the specified new root directorye"
9 HOMEPAGE="https://github.com/archlinux/arch-install-scripts https://man.archlinux.org/man/pacstrap.8"
10 SRC_URI="https://github.com/archlinux/arch-install-scripts/archive/refs/tags/v${PV}.tar.gz -> arch-install-scripts-v${PV}.tar.gz"
12 S="${WORKDIR}/arch-install-scripts-${PV}"
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="~amd64"
17 IUSE="test"
18 RESTRICT="!test? ( test )"
20 BDEPEND="
21         app-alternatives/awk
22         app-text/asciidoc
24 DEPEND="sys-apps/pacman"
26 src_test() {
27         emake MANS="doc/pacstrap.8" BINPROGS="pacstrap" check
30 src_compile() {
31         emake MANS="doc/pacstrap.8" BINPROGS="pacstrap"
34 src_install() {
35         dobin pacstrap
36         doman doc/pacstrap.8
37         newbashcomp completion/pacstrap.bash pacstrap