net-proxy/clash-nyanpasu: add 1.5.1, drop 1.5.0
[gentoo-zh.git] / media-plugins / waylyrics / waylyrics-0.2.15.ebuild
blob2b1fbcc76b5564e1f751022d91e3fc6d48881a76
1 # Copyright 2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 # Autogenerated by pycargoebuild 0.13.2
6 EAPI=8
8 CRATES="
9         addr2line@0.21.0
10         adler@1.0.2
11         aes@0.8.4
12         ahash@0.7.8
13         aho-corasick@1.1.3
14         ansi_term@0.12.1
15         anyhow@1.0.81
16         arrayvec@0.7.4
17         assert_float_eq@1.1.3
18         async-channel@2.2.0
19         async-trait@0.1.79
20         atty@0.2.14
21         autocfg@1.2.0
22         backtrace@0.3.71
23         base64@0.21.7
24         base64@0.22.0
25         base64ct@1.6.0
26         bitflags@1.3.2
27         bitflags@2.5.0
28         bitvec@1.0.1
29         block-padding@0.3.3
30         block@0.1.6
31         borsh-derive@1.4.0
32         borsh@1.4.0
33         bumpalo@3.15.4
34         bytecheck@0.6.12
35         bytecheck_derive@0.6.12
36         byteorder@1.5.0
37         bytes@1.6.0
38         cairo-rs@0.19.2
39         cairo-sys-rs@0.19.2
40         cbc@0.1.2
41         cc@1.0.90
42         cfg-expr@0.15.7
43         cfg-if@1.0.0
44         cfg_aliases@0.1.1
45         cipher@0.4.4
46         clap@2.34.0
47         concurrent-queue@2.4.0
48         const-oid@0.9.6
49         cookie@0.17.0
50         cookie@0.18.1
51         cookie_store@0.20.0
52         core-foundation-sys@0.8.6
53         core-foundation@0.9.4
54         cpufeatures@0.2.12
55         crossbeam-utils@0.8.19
56         crypto-common@0.1.6
57         darling@0.14.4
58         darling_core@0.14.4
59         darling_macro@0.14.4
60         dbus-codegen@0.9.1
61         dbus-dummy@0.1.0
62         dbus-tree@0.9.2
63         dbus@0.9.7
64         der@0.7.9
65         deranged@0.3.11
66         derive_is_enum_variant@0.1.1
67         digest@0.10.7
68         directories@5.0.1
69         dirs-sys@0.4.1
70         documented-derive@0.4.0
71         documented@0.4.0
72         ecb@0.1.2
73         encoding_rs@0.8.33
74         enum-kinds@0.5.1
75         equivalent@1.0.1
76         errno@0.3.8
77         event-listener-strategy@0.5.1
78         event-listener@5.2.0
79         fastrand@2.0.2
80         field-offset@0.3.6
81         fnv@1.0.7
82         foreign-types-shared@0.1.1
83         foreign-types@0.3.2
84         form_urlencoded@1.2.1
85         from_variants@1.0.2
86         from_variants_impl@1.0.2
87         funty@2.0.0
88         futures-channel@0.3.30
89         futures-core@0.3.30
90         futures-executor@0.3.30
91         futures-io@0.3.30
92         futures-macro@0.3.30
93         futures-sink@0.3.30
94         futures-task@0.3.30
95         futures-util@0.3.30
96         gdk-pixbuf-sys@0.19.0
97         gdk-pixbuf@0.19.2
98         gdk4-sys@0.8.1
99         gdk4-win32-sys@0.8.1
100         gdk4-win32@0.8.1
101         gdk4@0.8.1
102         generic-array@0.14.7
103         getrandom@0.2.12
104         gettext-rs@0.7.0
105         gettext-sys@0.21.3
106         gimli@0.28.1
107         gio-sys@0.19.0
108         gio@0.19.3
109         glib-macros@0.19.3
110         glib-sys@0.19.0
111         glib@0.19.3
112         gobject-sys@0.19.0
113         graphene-rs@0.19.2
114         graphene-sys@0.19.0
115         gsk4-sys@0.8.1
116         gsk4@0.8.1
117         gtk4-macros@0.8.1
118         gtk4-sys@0.8.1
119         gtk4@0.8.1
120         h2@0.4.3
121         hashbrown@0.12.3
122         hashbrown@0.14.3
123         heck@0.3.3
124         heck@0.4.1
125         heck@0.5.0
126         hermit-abi@0.1.19
127         hermit-abi@0.3.9
128         hex@0.4.3
129         http-body-util@0.1.1
130         http-body@1.0.0
131         http@1.1.0
132         httparse@1.8.0
133         hyper-tls@0.6.0
134         hyper-util@0.1.3
135         hyper@1.2.0
136         ident_case@1.0.1
137         idna@0.3.0
138         idna@0.5.0
139         indexmap@2.2.6
140         inout@0.1.3
141         ipnet@2.9.0
142         itoa@1.0.11
143         js-sys@0.3.69
144         ksni-dummy@0.1.0
145         ksni@0.2.1
146         lazy_static@1.4.0
147         libc@0.2.153
148         libdbus-sys@0.2.5
149         libm@0.2.8
150         libmimalloc-sys@0.1.35
151         libredox@0.1.3
152         linux-raw-sys@0.4.13
153         locale_config@0.3.0
154         lock_api@0.4.11
155         log@0.4.21
156         lrc-nom@0.2.0
157         malloc_buf@0.0.6
158         matchers@0.1.0
159         md5@0.7.0
160         memchr@2.7.2
161         memoffset@0.9.1
162         mimalloc@0.1.39
163         mime@0.3.17
164         minimal-lexical@0.2.1
165         miniz_oxide@0.7.2
166         mio@0.8.11
167         mpris@2.0.1
168         native-tls@0.2.11
169         nom@7.1.3
170         nu-ansi-term@0.46.0
171         num-bigint-dig@0.8.4
172         num-conv@0.1.0
173         num-integer@0.1.46
174         num-iter@0.1.44
175         num-traits@0.2.18
176         num_cpus@1.16.0
177         objc-foundation@0.1.1
178         objc@0.2.7
179         objc_id@0.1.1
180         object@0.32.2
181         once_cell@1.19.0
182         openssl-macros@0.1.1
183         openssl-probe@0.1.5
184         openssl-sys@0.9.102
185         openssl@0.10.64
186         option-ext@0.2.0
187         overload@0.1.1
188         pango-sys@0.19.0
189         pango@0.19.3
190         parking@2.2.0
191         parking_lot@0.12.1
192         parking_lot_core@0.9.9
193         pem-rfc7468@0.7.0
194         percent-encoding@2.3.1
195         phf@0.11.2
196         phf_generator@0.11.2
197         phf_macros@0.11.2
198         phf_shared@0.11.2
199         pin-project-internal@1.1.5
200         pin-project-lite@0.2.14
201         pin-project@1.1.5
202         pin-utils@0.1.0
203         pkcs1@0.7.5
204         pkcs8@0.10.2
205         pkg-config@0.3.30
206         powerfmt@0.2.0
207         ppv-lite86@0.2.17
208         proc-macro-crate@3.1.0
209         proc-macro-error-attr@1.0.4
210         proc-macro-error@1.0.4
211         proc-macro2@1.0.79
212         psl-types@2.0.11
213         ptr_meta@0.1.4
214         ptr_meta_derive@0.1.4
215         publicsuffix@2.2.3
216         quote@0.3.15
217         quote@1.0.35
218         radium@0.7.0
219         rand@0.8.5
220         rand_chacha@0.3.1
221         rand_core@0.6.4
222         redox_syscall@0.4.1
223         redox_users@0.4.5
224         regex-automata@0.1.10
225         regex-automata@0.4.6
226         regex-syntax@0.6.29
227         regex-syntax@0.8.3
228         regex@1.10.4
229         rend@0.4.2
230         reqwest@0.12.2
231         rkyv@0.7.44
232         rkyv_derive@0.7.44
233         rsa@0.9.6
234         rust_decimal@1.35.0
235         rust_decimal_macros@1.34.2
236         rustc-demangle@0.1.23
237         rustc_version@0.4.0
238         rustix@0.38.32
239         rustls-pemfile@1.0.4
240         rustversion@1.0.14
241         ryu@1.0.17
242         schannel@0.1.23
243         scopeguard@1.2.0
244         seahash@4.1.0
245         security-framework-sys@2.10.0
246         security-framework@2.10.0
247         semver@1.0.22
248         serde@1.0.197
249         serde_derive@1.0.197
250         serde_json@1.0.115
251         serde_repr@0.1.18
252         serde_spanned@0.6.5
253         serde_urlencoded@0.7.1
254         sharded-slab@0.1.7
255         signal-hook-registry@1.4.1
256         signature@2.2.0
257         simdutf8@0.1.4
258         siphasher@0.3.11
259         slab@0.4.9
260         smallvec@1.13.2
261         socket2@0.5.6
262         sorensen@0.2.0
263         spin@0.5.2
264         spki@0.7.3
265         strsim@0.10.0
266         strsim@0.8.0
267         strum@0.26.2
268         strum_macros@0.26.2
269         subtle@2.5.0
270         syn@0.11.11
271         syn@1.0.109
272         syn@2.0.57
273         syn_derive@0.1.8
274         sync_wrapper@0.1.2
275         synom@0.11.3
276         system-configuration-sys@0.5.0
277         system-configuration@0.5.1
278         system-deps@6.2.2
279         tap@1.0.1
280         target-lexicon@0.12.14
281         temp-dir@0.1.13
282         tempfile@3.10.1
283         textwrap@0.11.0
284         thiserror-impl@1.0.58
285         thiserror@1.0.58
286         thread_local@1.1.8
287         time-core@0.1.2
288         time-macros@0.2.17
289         time@0.3.34
290         tinyvec@1.6.0
291         tinyvec_macros@0.1.1
292         tokio-macros@2.2.0
293         tokio-native-tls@0.3.1
294         tokio-util@0.7.10
295         tokio@1.37.0
296         toml@0.8.12
297         toml_datetime@0.6.5
298         toml_edit@0.21.1
299         toml_edit@0.22.9
300         tower-layer@0.3.2
301         tower-service@0.3.2
302         tower@0.4.13
303         tracing-attributes@0.1.27
304         tracing-core@0.1.32
305         tracing-journald@0.3.0
306         tracing-log@0.2.0
307         tracing-subscriber@0.3.18
308         tracing@0.1.40
309         try-lock@0.2.5
310         typenum@1.17.0
311         unicode-bidi@0.3.15
312         unicode-ident@1.0.12
313         unicode-normalization@0.1.23
314         unicode-segmentation@1.11.0
315         unicode-width@0.1.11
316         unicode-xid@0.0.4
317         url@2.5.0
318         uuid@1.8.0
319         valuable@0.1.0
320         vcpkg@0.2.15
321         vec_map@0.8.2
322         version-compare@0.2.0
323         version_check@0.9.4
324         want@0.3.1
325         wasi@0.11.0+wasi-snapshot-preview1
326         wasm-bindgen-backend@0.2.92
327         wasm-bindgen-futures@0.4.42
328         wasm-bindgen-macro-support@0.2.92
329         wasm-bindgen-macro@0.2.92
330         wasm-bindgen-shared@0.2.92
331         wasm-bindgen@0.2.92
332         web-sys@0.3.69
333         winapi-i686-pc-windows-gnu@0.4.0
334         winapi-x86_64-pc-windows-gnu@0.4.0
335         winapi@0.3.9
336         windows-core@0.54.0
337         windows-result@0.1.0
338         windows-sys@0.48.0
339         windows-sys@0.52.0
340         windows-targets@0.48.5
341         windows-targets@0.52.4
342         windows@0.54.0
343         windows_aarch64_gnullvm@0.48.5
344         windows_aarch64_gnullvm@0.52.4
345         windows_aarch64_msvc@0.48.5
346         windows_aarch64_msvc@0.52.4
347         windows_i686_gnu@0.48.5
348         windows_i686_gnu@0.52.4
349         windows_i686_msvc@0.48.5
350         windows_i686_msvc@0.52.4
351         windows_x86_64_gnu@0.48.5
352         windows_x86_64_gnu@0.52.4
353         windows_x86_64_gnullvm@0.48.5
354         windows_x86_64_gnullvm@0.52.4
355         windows_x86_64_msvc@0.48.5
356         windows_x86_64_msvc@0.52.4
357         winnow@0.5.40
358         winnow@0.6.5
359         winreg@0.50.0
360         wyz@0.5.1
361         xml-rs@0.8.20
362         zeroize@1.7.0
365 declare -A GIT_CRATES=(
366         [ncmapi]='https://github.com/waylyrics/ncmapi-rs;6095abf7e54eedbb716676d311e0741b4ac2482e;ncmapi-rs-%commit%'
367         [qqmusic-rs]='https://github.com/waylyrics/qqmusic-rs;22e66ba62e63d97c6dffb45400655404e6f06b93;qqmusic-rs-%commit%'
370 PLOCALES="zh_CN"
371 inherit cargo desktop gnome2-utils plocale xdg
373 DESCRIPTION="Simple On Screen lyrics Display for linux/unix"
374 HOMEPAGE="
375         https://waylyrics.github.io/waylyrics/waylyrics
376         https://github.com/waylyrics/waylyrics
379 if [[ "${PV}" == *9999* ]]; then
380         inherit git-r3
381         EGIT_REPO_URI="https://github.com/waylyrics/waylyrics.git"
382 else
383         SRC_URI="
384                 https://github.com/waylyrics/waylyrics/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
385                 ${CARGO_CRATE_URIS}
386         "
387         KEYWORDS="~amd64"
390 LICENSE="MIT"
391 # Dependent crate licenses
392 LICENSE+="
393         Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD GPL-3+ MIT
394         Unicode-DFS-2016 Unlicense
396 SLOT="0"
398 DEPEND="
399         dev-libs/glib:2
400         gui-libs/gtk:4
401         dev-libs/openssl:=
402         sys-apps/dbus
403         sys-devel/gettext
404         x11-libs/cairo
406 RDEPEND="${DEPEND}"
407 BDEPEND="
408         app-misc/jq
409         dev-libs/mimalloc
410         >=virtual/rust-1.73:*
413 src_compile() {
414         export WAYLYRICS_THEME_PRESETS_DIR="/usr/share/${PN}/themes"
415         cargo_src_compile --all-targets --all-features
418 src_install() {
419         cargo_src_install
421         doicon -s scalable "${S}/res/icons/hicolor/scalable/apps/io.poly000.waylyrics.svg"
422         domenu "${S}/io.poly000.waylyrics.desktop"
424         insinto "/usr/share/glib-2.0/schemas"
425         doins "io.poly000.waylyrics.gschema.xml"
427         insinto "/usr/share/${PN}"
428         doins -r themes
430         cd "${S}/locales" || die
431         install_locale() {
432                 if [[ -f ${1}/LC_MESSAGES/waylyrics.po ]]; then
433                         local file=${1}/LC_MESSAGES/waylyrics.po
434                         msgfmt "${file}" -o "${file%.po}.mo" || die
435                         insinto /usr/share/locale/${1}/LC_MESSAGES
436                         doins "${file%.po}.mo"
437                 fi
438         }
439         plocale_for_each_locale install_locale
442 pkg_postinst() {
443         gnome2_schemas_update
444         xdg_pkg_postinst
447 pkg_postrm() {
448         gnome2_schemas_update
449         xdg_pkg_postrm