1 # Copyright 2023-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 inherit go-module systemd
8 DESCRIPTION="Automatically obtain your public IP address and set to your domain name service."
9 HOMEPAGE="https://github.com/jeessy2/ddns-go"
10 SRC_URI="https://github.com/jeessy2/ddns-go/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
11 https://dev.dream-universe.org/distfiles/${P}-vendor.tar.xz"
15 KEYWORDS="~amd64 ~riscv"
18 "${FILESDIR}/${PN}-6.7.2-remove-update-support.patch"
19 "${FILESDIR}/${PN}-6.6.2-remove-service-management-support.patch"
20 "${FILESDIR}/${PN}-6.7.1-deps-tidy.patch"
26 -ldflags="-s -w -linkmode external \
27 -X 'main.version=${PV} (Gentoo)' \
28 -X 'main.buildTime=$(date -u +"%Y-%m-%dT%H:%M:%SZ")'" \
35 systemd_dounit "${FILESDIR}/${PN}.service"
36 systemd_newunit "${FILESDIR}/${PN}_at.service" "${PN}@.service"
37 systemd_dounit "${FILESDIR}/${PN}-web.service"