sci-electronics/lceda-pro: bump version to 2.2.34.5
[gentoo-zh.git] / net-proxy / shadowsocks-rust / shadowsocks-rust-1.21.0.ebuild
blob8048d96e4e8dfeff41b102806e321ec493ac22cb
1 # Copyright 2022-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 # Auto-Generated by cargo-ebuild 0.5.4-r1
6 EAPI=8
8 CRATES="
9         addr2line@0.24.1
10         adler2@2.0.0
11         aead@0.5.2
12         aes@0.8.4
13         aes-gcm@0.10.3
14         aes-gcm-siv@0.11.1
15         ahash@0.8.11
16         aho-corasick@1.1.3
17         alloc-no-stdlib@2.0.4
18         alloc-stdlib@0.2.2
19         android-tzdata@0.1.1
20         android_system_properties@0.1.5
21         anstream@0.6.15
22         anstyle@1.0.8
23         anstyle-parse@0.2.5
24         anstyle-query@1.1.1
25         anstyle-wincon@3.0.4
26         anyhow@1.0.89
27         arc-swap@1.7.1
28         arrayref@0.3.9
29         arrayvec@0.7.6
30         async-channel@2.3.1
31         async-compression@0.4.12
32         async-task@4.7.1
33         async-trait@0.1.82
34         atomic-waker@1.1.2
35         autocfg@1.3.0
36         backtrace@0.3.74
37         base16ct@0.2.0
38         base64@0.13.1
39         base64@0.21.7
40         base64@0.22.1
41         base64ct@1.6.0
42         bit-vec@0.7.0
43         bitflags@1.3.2
44         bitflags@2.6.0
45         bitvec@1.0.1
46         blake3@1.5.4
47         block-buffer@0.10.4
48         blocking@1.6.1
49         bloomfilter@1.0.14
50         brotli@6.0.0
51         brotli-decompressor@4.0.1
52         bson@2.13.0
53         build-time@0.1.3
54         bumpalo@3.16.0
55         byte_string@1.0.0
56         byteorder@1.5.0
57         bytes@1.7.2
58         c2rust-bitfields@0.19.0
59         c2rust-bitfields-derive@0.19.0
60         camellia@0.1.0
61         cc@1.1.21
62         ccm@0.5.0
63         cfg-if@1.0.0
64         cfg_aliases@0.2.1
65         chacha20@0.9.1
66         chacha20poly1305@0.10.1
67         chrono@0.4.38
68         cipher@0.4.4
69         clap@4.5.18
70         clap_builder@4.5.18
71         clap_lex@0.7.2
72         cmake@0.1.51
73         colorchoice@1.0.2
74         concurrent-queue@2.5.0
75         const-oid@0.9.6
76         constant_time_eq@0.3.1
77         core-foundation@0.9.4
78         core-foundation-sys@0.8.7
79         cpufeatures@0.2.14
80         crc32fast@1.4.2
81         crossbeam-channel@0.5.13
82         crossbeam-epoch@0.9.18
83         crossbeam-utils@0.8.20
84         crypto-bigint@0.5.5
85         crypto-common@0.1.6
86         ctr@0.9.2
87         daemonize@0.5.0
88         data-encoding@2.6.0
89         defmt@0.3.8
90         defmt-macros@0.3.9
91         defmt-parser@0.3.4
92         der@0.7.9
93         deranged@0.3.11
94         derivative@2.2.0
95         destructure_traitobject@0.2.0
96         digest@0.10.7
97         directories@5.0.1
98         dirs-sys@0.4.1
99         displaydoc@0.2.5
100         ecdsa@0.16.9
101         ed25519@2.2.3
102         elliptic-curve@0.13.8
103         encoding_rs@0.8.34
104         enum-as-inner@0.6.1
105         env_filter@0.1.2
106         env_logger@0.11.5
107         equivalent@1.0.1
108         errno@0.3.9
109         etherparse@0.16.0
110         event-listener@5.3.1
111         event-listener-strategy@0.5.2
112         fastrand@1.9.0
113         fastrand@2.1.1
114         ff@0.13.0
115         filetime@0.2.25
116         flate2@1.0.33
117         fnv@1.0.7
118         foreign-types@0.3.2
119         foreign-types-shared@0.1.1
120         form_urlencoded@1.2.1
121         fs2@0.4.3
122         fsevent-sys@4.1.0
123         funty@2.0.0
124         futures@0.3.30
125         futures-channel@0.3.30
126         futures-core@0.3.30
127         futures-executor@0.3.30
128         futures-io@0.3.30
129         futures-lite@2.3.0
130         futures-macro@0.3.30
131         futures-sink@0.3.30
132         futures-task@0.3.30
133         futures-util@0.3.30
134         fxhash@0.2.1
135         generic-array@0.14.7
136         getrandom@0.2.15
137         ghash@0.5.1
138         gimli@0.31.0
139         group@0.13.0
140         h2@0.3.26
141         h2@0.4.6
142         h3@0.0.2
143         h3-quinn@0.0.3
144         hash32@0.3.1
145         hashbrown@0.14.5
146         heapless@0.8.0
147         heck@0.5.0
148         hermit-abi@0.3.9
149         hex@0.4.3
150         hickory-proto@0.24.1
151         hickory-resolver@0.24.1
152         hkdf@0.12.4
153         hmac@0.12.1
154         hostname@0.3.1
155         http@0.2.12
156         http@1.1.0
157         http-body@1.0.1
158         http-body-util@0.1.2
159         httparse@1.9.4
160         httpdate@1.0.3
161         humantime@2.1.0
162         hyper@1.4.1
163         hyper-rustls@0.27.3
164         hyper-tls@0.6.0
165         hyper-util@0.1.8
166         iana-time-zone@0.1.61
167         iana-time-zone-haiku@0.1.2
168         icu_collections@1.5.0
169         icu_locid@1.5.0
170         icu_locid_transform@1.5.0
171         icu_locid_transform_data@1.5.0
172         icu_normalizer@1.5.0
173         icu_normalizer_data@1.5.0
174         icu_properties@1.5.1
175         icu_properties_data@1.5.0
176         icu_provider@1.5.0
177         icu_provider_macros@1.5.0
178         idna@0.4.0
179         idna@0.5.0
180         idna@1.0.2
181         indexmap@2.5.0
182         inotify@0.9.6
183         inotify-sys@0.1.5
184         inout@0.1.3
185         instant@0.1.13
186         ipconfig@0.3.2
187         ipnet@2.10.0
188         iprange@0.6.7
189         is_terminal_polyfill@1.70.1
190         itoa@1.0.11
191         jemalloc-sys@0.5.4+5.3.0-patched
192         jemallocator@0.5.4
193         jobserver@0.1.32
194         js-sys@0.3.70
195         json5@0.4.1
196         kqueue@1.0.8
197         kqueue-sys@1.0.4
198         lazy_static@1.5.0
199         libc@0.2.158
200         libloading@0.8.5
201         libmimalloc-sys@0.1.39
202         libredox@0.1.3
203         linked-hash-map@0.5.6
204         linux-raw-sys@0.4.14
205         litemap@0.7.3
206         lock_api@0.4.12
207         log@0.4.22
208         log-mdc@0.1.0
209         log4rs@1.3.0
210         lru-cache@0.1.2
211         lru_time_cache@0.11.11
212         managed@0.8.0
213         match_cfg@0.1.0
214         matchers@0.1.0
215         md-5@0.10.6
216         memchr@2.7.4
217         mimalloc@0.1.43
218         mime@0.3.17
219         miniz_oxide@0.8.0
220         mio@0.8.11
221         mio@1.0.2
222         native-tls@0.2.12
223         nix@0.29.0
224         notify@6.1.1
225         nu-ansi-term@0.46.0
226         num-conv@0.1.0
227         num-traits@0.2.19
228         num_threads@0.1.7
229         object@0.36.4
230         once_cell@1.19.0
231         opaque-debug@0.3.1
232         openssl@0.10.66
233         openssl-macros@0.1.1
234         openssl-probe@0.1.5
235         openssl-src@300.3.2+3.3.2
236         openssl-sys@0.9.103
237         option-ext@0.2.0
238         ordered-float@2.10.1
239         overload@0.1.1
240         p256@0.13.2
241         p384@0.13.0
242         parking@2.2.1
243         parking_lot@0.11.2
244         parking_lot@0.12.3
245         parking_lot_core@0.8.6
246         parking_lot_core@0.9.10
247         percent-encoding@2.3.1
248         pest@2.7.13
249         pest_derive@2.7.13
250         pest_generator@2.7.13
251         pest_meta@2.7.13
252         pin-project@1.1.5
253         pin-project-internal@1.1.5
254         pin-project-lite@0.2.14
255         pin-utils@0.1.0
256         piper@0.2.4
257         pkcs8@0.10.2
258         pkg-config@0.3.30
259         poly1305@0.8.0
260         polyval@0.6.2
261         powerfmt@0.2.0
262         ppv-lite86@0.2.20
263         primeorder@0.13.6
264         proc-macro-error@1.0.4
265         proc-macro-error-attr@1.0.4
266         proc-macro2@1.0.86
267         qrcode@0.14.1
268         quick-error@1.2.3
269         quinn@0.10.2
270         quinn@0.11.5
271         quinn-proto@0.10.6
272         quinn-proto@0.11.8
273         quinn-udp@0.4.1
274         quinn-udp@0.5.5
275         quote@1.0.37
276         radium@0.7.0
277         rand@0.8.5
278         rand_chacha@0.3.1
279         rand_core@0.6.4
280         redox_syscall@0.2.16
281         redox_syscall@0.5.4
282         redox_users@0.4.6
283         regex@1.10.6
284         regex-automata@0.1.10
285         regex-automata@0.4.7
286         regex-syntax@0.6.29
287         regex-syntax@0.8.4
288         reqwest@0.12.7
289         resolv-conf@0.7.0
290         ring@0.16.20
291         ring@0.17.8
292         ring-compat@0.8.0
293         rpassword@7.3.1
294         rpmalloc@0.2.2
295         rpmalloc-sys@0.2.3+b097fd0
296         rtoolbox@0.0.2
297         rustc-demangle@0.1.24
298         rustc-hash@1.1.0
299         rustc-hash@2.0.0
300         rustix@0.38.37
301         rustls@0.21.12
302         rustls@0.23.13
303         rustls-native-certs@0.6.3
304         rustls-native-certs@0.7.3
305         rustls-native-certs@0.8.0
306         rustls-pemfile@1.0.4
307         rustls-pemfile@2.1.3
308         rustls-pki-types@1.8.0
309         rustls-webpki@0.101.7
310         rustls-webpki@0.102.8
311         ryu@1.0.18
312         same-file@1.0.6
313         schannel@0.1.24
314         scopeguard@1.2.0
315         sct@0.7.1
316         sec1@0.7.3
317         security-framework@2.11.1
318         security-framework-sys@2.12.0
319         sendfd@0.4.3
320         serde@1.0.210
321         serde-value@0.7.0
322         serde_bytes@0.11.15
323         serde_derive@1.0.210
324         serde_json@1.0.128
325         serde_urlencoded@0.7.1
326         serde_yaml@0.9.34+deprecated
327         sha1@0.10.6
328         sha2@0.10.8
329         shadowsocks-crypto@0.5.5
330         sharded-slab@0.1.7
331         shlex@1.3.0
332         signal-hook-registry@1.4.2
333         signature@2.2.0
334         siphasher@1.0.1
335         slab@0.4.9
336         sled@0.34.7
337         sm4@0.5.1
338         smallvec@1.13.2
339         smoltcp@0.11.0
340         snmalloc-rs@0.3.6
341         snmalloc-sys@0.3.6
342         socket2@0.5.7
343         spin@0.5.2
344         spin@0.9.8
345         spki@0.7.3
346         stable_deref_trait@1.2.0
347         strsim@0.11.1
348         subtle@2.6.1
349         syn@1.0.109
350         syn@2.0.77
351         sync_wrapper@1.0.1
352         synstructure@0.13.1
353         sysexits@0.8.2
354         system-configuration@0.6.1
355         system-configuration-sys@0.6.0
356         tap@1.0.1
357         tcmalloc@0.3.0
358         tcmalloc-sys@0.3.0
359         tempfile@3.12.0
360         terminal_size@0.3.0
361         thiserror@1.0.63
362         thiserror-impl@1.0.63
363         thread-id@4.2.2
364         thread_local@1.1.8
365         time@0.3.36
366         time-core@0.1.2
367         time-macros@0.2.18
368         tinystr@0.7.6
369         tinyvec@1.8.0
370         tinyvec_macros@0.1.1
371         tokio@1.40.0
372         tokio-macros@2.4.0
373         tokio-native-tls@0.3.1
374         tokio-rustls@0.24.1
375         tokio-rustls@0.26.0
376         tokio-tfo@0.3.1
377         tokio-util@0.7.12
378         tower@0.4.13
379         tower-layer@0.3.3
380         tower-service@0.3.3
381         tracing@0.1.40
382         tracing-attributes@0.1.27
383         tracing-core@0.1.32
384         tracing-log@0.2.0
385         tracing-subscriber@0.3.18
386         try-lock@0.2.5
387         tun2@3.1.4
388         typemap-ors@1.0.0
389         typenum@1.17.0
390         ucd-trie@0.1.6
391         unicode-bidi@0.3.15
392         unicode-ident@1.0.13
393         unicode-normalization@0.1.24
394         universal-hash@0.5.1
395         unsafe-any-ors@1.0.0
396         unsafe-libyaml@0.2.11
397         untrusted@0.7.1
398         untrusted@0.9.0
399         url@2.5.2
400         utf16_iter@1.0.5
401         utf8_iter@1.0.4
402         utf8parse@0.2.2
403         uuid@1.10.0
404         valuable@0.1.0
405         vcpkg@0.2.15
406         version_check@0.9.5
407         walkdir@2.5.0
408         want@0.3.1
409         wasi@0.11.0+wasi-snapshot-preview1
410         wasm-bindgen@0.2.93
411         wasm-bindgen-backend@0.2.93
412         wasm-bindgen-futures@0.4.43
413         wasm-bindgen-macro@0.2.93
414         wasm-bindgen-macro-support@0.2.93
415         wasm-bindgen-shared@0.2.93
416         web-sys@0.3.70
417         webpki-roots@0.25.4
418         webpki-roots@0.26.6
419         widestring@1.1.0
420         winapi@0.3.9
421         winapi-i686-pc-windows-gnu@0.4.0
422         winapi-util@0.1.9
423         winapi-x86_64-pc-windows-gnu@0.4.0
424         windows-core@0.52.0
425         windows-registry@0.2.0
426         windows-result@0.2.0
427         windows-service@0.7.0
428         windows-strings@0.1.0
429         windows-sys@0.48.0
430         windows-sys@0.52.0
431         windows-sys@0.59.0
432         windows-targets@0.48.5
433         windows-targets@0.52.6
434         windows_aarch64_gnullvm@0.48.5
435         windows_aarch64_gnullvm@0.52.6
436         windows_aarch64_msvc@0.48.5
437         windows_aarch64_msvc@0.52.6
438         windows_i686_gnu@0.48.5
439         windows_i686_gnu@0.52.6
440         windows_i686_gnullvm@0.52.6
441         windows_i686_msvc@0.48.5
442         windows_i686_msvc@0.52.6
443         windows_x86_64_gnu@0.48.5
444         windows_x86_64_gnu@0.52.6
445         windows_x86_64_gnullvm@0.48.5
446         windows_x86_64_gnullvm@0.52.6
447         windows_x86_64_msvc@0.48.5
448         windows_x86_64_msvc@0.52.6
449         winreg@0.50.0
450         wintun-bindings@0.7.7
451         write16@1.0.0
452         writeable@0.5.5
453         wyz@0.5.1
454         xdg@2.5.2
455         yoke@0.7.4
456         yoke-derive@0.7.4
457         zerocopy@0.7.35
458         zerocopy-derive@0.7.35
459         zerofrom@0.1.4
460         zerofrom-derive@0.1.4
461         zeroize@1.8.1
462         zerovec@0.10.4
463         zerovec-derive@0.10.3
464         zstd@0.13.2
465         zstd-safe@7.2.1
466         zstd-sys@2.0.13+zstd.1.5.6
469 inherit cargo linux-info systemd
471 MY_PV=${PV/_alpha/-alpha.}
473 DESCRIPTION="A Rust port of shadowsocks."
474 HOMEPAGE="https://github.com/shadowsocks/shadowsocks-rust"
475 SRC_URI="https://github.com/shadowsocks/shadowsocks-rust/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz
476         ${CARGO_CRATE_URIS}"
478 S="${WORKDIR}/${PN}-${MY_PV}"
480 LICENSE="MIT"
481 LICENSE+="
482         0BSD Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD BSD-2 Boost-1.0 CC0-1.0
483         ISC MIT-0 MPL-2.0 Unicode-3.0 Unicode-DFS-2016 Unlicense WTFPL-2 ZLIB
485 SLOT="0"
486 KEYWORDS="~amd64 ~arm64"
487 IUSE="redir tun"
489 QA_FLAGS_IGNORED="
490         usr/bin/sslocal
491         usr/bin/ssmanager
492         usr/bin/ssurl
493         usr/bin/ssservice
494         usr/bin/ssserver
497 pkg_setup() {
498         if use tun; then
499                 CONFIG_CHECK="~TUN"
500                 linux-info_pkg_setup
501         fi
502         rust_pkg_setup
505 src_configure() {
506         local myfeatures=(
507                 $(usex redir local-redir "")
508                 $(usex tun local-tun "")
509         )
510         cargo_src_configure
513 src_install() {
514         cargo_src_install
516         systemd_newunit "${FILESDIR}/shadowsocks-rust_at.service" shadowsocks-rust@.service
517         systemd_newunit "${FILESDIR}/shadowsocks-rust-server_at.service" shadowsocks-rust-server@.service
519         insinto "/etc/${PN}"
520         doins examples/*.json