app-editors/cursor: add 0.42.5, drop 0.42.4
[gentoo-zh.git] / net-proxy / cgproxy / cgproxy-0.20-r1.ebuild
blob607c457a8d06b0aa90d0c7282f436776abbe5607
1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit cmake
8 DESCRIPTION="Transparent Proxy with cgroup v2"
9 HOMEPAGE="https://github.com/springzfx/cgproxy"
10 SRC_URI="https://github.com/springzfx/cgproxy/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64"
16 DEPEND="
17 net-firewall/iptables
18 dev-util/bcc
20 RDEPEND="${DEPEND}"
21 BDEPEND="
22 dev-cpp/nlohmann_json
23 dev-libs/libbpf
24 dev-util/bpftool
25 sys-devel/clang
28 src_prepare() {
29 # fix build error (clang-15)
30 sed -i 's!clang -O2!clang -O2 -fno-stack-protector!' execsnoop-libbpf/CMakeLists.txt || die
31 cmake_src_prepare
34 src_install() {
35 cmake_src_install
36 rm -r "${D}"/usr/share/man/man1 || die
37 doman man/*.1