app-i18n/fcitx5-configtool: bump to 5.0.12
[gentoo-zh.git] / media-fonts / lxgwwenkai / lxgwwenkai-1.120.ebuild
blobaa2a32262616a9ff46d3922f596a9ad8fa43f3f5
1 # Copyright 1999-2022 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 inherit font
7 WENKAI="LXGWWenKai"
8 WENKAI_MONO="LXGWWenKaiMono"
9 LATIN_FONTS_DIR="LxgwWenKai-${PV}/MonoLatin"
11 WENKAI_CJK=(
12 "${WENKAI}-Bold-${PV}.ttf"
13 "${WENKAI}-Light-${PV}.ttf"
14 "${WENKAI}-Regular-${PV}.ttf"
15 "${WENKAI_MONO}-Bold-${PV}.ttf"
16 "${WENKAI_MONO}-Light-${PV}.ttf"
17 "${WENKAI_MONO}-Regular-${PV}.ttf"
20 DESCRIPTION="An open-source Chinese font derived from Fontworks' Klee One."
21 HOMEPAGE="https://lxgw.github.io/2021/01/28/Klee-Simpchin"
22 SRC_URI="https://github.com/lxgw/LxgwWenKai/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
23 SRC_URI+=" https://github.com/lxgw/LxgwWenKai/releases/download/v${PV}/${WENKAI}-Bold.ttf -> ${WENKAI}-Bold-${PV}.ttf"
24 SRC_URI+=" https://github.com/lxgw/LxgwWenKai/releases/download/v${PV}/${WENKAI}-Light.ttf -> ${WENKAI}-Light-${PV}.ttf"
25 SRC_URI+=" https://github.com/lxgw/LxgwWenKai/releases/download/v${PV}/${WENKAI}-Regular.ttf -> ${WENKAI}-Regular-${PV}.ttf"
26 SRC_URI+=" https://github.com/lxgw/LxgwWenKai/releases/download/v${PV}/${WENKAI_MONO}-Bold.ttf -> ${WENKAI_MONO}-Bold-${PV}.ttf"
27 SRC_URI+=" https://github.com/lxgw/LxgwWenKai/releases/download/v${PV}/${WENKAI_MONO}-Light.ttf -> ${WENKAI_MONO}-Light-${PV}.ttf"
28 SRC_URI+=" https://github.com/lxgw/LxgwWenKai/releases/download/v${PV}/${WENKAI_MONO}-Regular.ttf -> ${WENKAI_MONO}-Regular-${PV}.ttf"
30 S="${WORKDIR}"
31 LICENSE="OFL-1.1"
32 SLOT="0"
33 KEYWORDS="~amd64"
34 IUSE=""
36 RDEPEND=""
37 DEPEND=""
38 BDEPEND=""
39 FONT_SUFFIX="ttf"
40 FONT_S=(
41 "${S}/${LATIN_FONTS_DIR}"
42 "${S}"
45 src_unpack() {
46 default
48 # CJK fonts are not included in the tarball
49 # need to copy them to the ${S} dir for installation
50 for font in "${WENKAI_CJK[@]}"; do
51 cp "${DISTDIR}/${font}" "${S}"/ || die
52 done