app-i18n/fcitx5-configtool: bump to 5.0.12
[gentoo-zh.git] / x11-misc / ly / ly-0.5.3.ebuild
blob8f5a343ae074e6e7b1ec00f3f7491e57b56e1bc7
1 # Copyright 2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 inherit git-r3
8 DESCRIPTION="Ly - a TUI display manager"
9 HOMEPAGE="https://github.com/nullgemm/ly"
10 SRC_URI="https://github.com/nullgemm/ly/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
11 EGIT_CHECKOUT_DIR="${S}/sub"
13 LICENSE="WTFPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64"
17 DEPEND="sys-libs/pam
18 x11-libs/libxcb
19 x11-base/xorg-server
20 x11-apps/xauth"
21 RDEPEND="${DEPEND}"
22 BDEPEND=""
24 src_unpack() {
25 if [[ -n ${A} ]]; then
26 unpack ${A} || die
28 for _i in argoat configator dragonfail termbox_next; do
29 git-r3_fetch ${HOMEPAGE%ly}${_i} || die
30 git-r3_checkout ${HOMEPAGE%ly}${_i} ${EGIT_CHECKOUT_DIR}/${_i} || die
31 done