1 # Copyright 2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 DESCRIPTION
="Fast, disk space efficient package manager"
7 HOMEPAGE
="https://pnpm.io"
9 # Use the following command to create this package
11 # --cache "${PWD}/npm-cache" \
12 # --prefix "${PWD}/pkgdir" \
14 SRC_URI
="https://github.com/st0nie/gentoo-go-deps/releases/download/${P}/${P}-pkg.tar.xz -> ${P}.tar.xz"
20 DEPEND
="net-libs/nodejs"
27 mkdir
"${D}/usr" || die
28 cp -r * "${D}/usr" || die
29 fowners
-R root
:root
/usr
30 find "${D}/usr/lib64" -depth -name "*.map" -delete || die
32 local _tmp_package
="$(mktemp || die)"
33 local _npmdir
=/usr
/lib64
/node_modules
/${PN}
34 jq
'.|=with_entries(select(.key|test("_.+")|not))' "${D}/$_npmdir/package.json" > "$_tmp_package" || die
36 newins
$_tmp_package package.json
37 fperms
644 $_npmdir/package.json