kde-misc/plasma-applet-netspeed-widget: add 3.1
[gentoo-zh.git] / x11-themes / lxice / lxice-0.1.0.ebuild
blob9f32c7dce4ba3f381806452511b4fa4367573d06
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 DESCRIPTION="LXDE theme for IceWM"
7 HOMEPAGE="http://lxde.sf.net/"
8 SRC_URI="mirror://sourceforge/lxde/${PN}.tar.bz2"
10 SLOT="0"
12 LICENSE="GPL-2"
13 KEYWORDS="amd64 ~ppc sparc ~x86"
15 RDEPEND="x11-wm/icewm"
17 S="${WORKDIR}"
19 src_unpack() {
20         unpack ${A}
21         cd "${S}"
22         find . -name \.xvpics | xargs rm -rf
23         find . -name \*~ | xargs rm -rf
24         find . -name .svn | xargs rm -rf
27 src_install() {
28         local ICEWM_THEMES=/usr/share/icewm/themes
29         dodir "${ICEWM_THEMES}"
30         cp -pR * "${D}/${ICEWM_THEMES}"
31         chown -R root:0 "${D}/${ICEWM_THEMES}"
32         rm -f "${D}/${ICEWM_THEMES}/Crus-IceWM/cpframes.sh" || die
33         find "${D}/${ICEWM_THEMES}" -type d | xargs chmod 755 || die
34         find "${D}/${ICEWM_THEMES}" -type f | xargs chmod 644 || die