1 # Copyright 2021-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 inherit systemd go-module
8 DESCRIPTION="A platform for building proxies to bypass network restrictions."
9 HOMEPAGE="https://www.v2fly.org/"
10 SRC_URI="https://github.com/v2fly/v2ray-core/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
11 https://github.com/Puqns67/gentoo-deps/releases/download/${P}/${P}-vendor.tar.xz"
13 S="${WORKDIR}/${PN}-core-${PV}"
17 KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
19 DEPEND="app-alternatives/v2ray-geoip
20 app-alternatives/v2ray-geosite"
21 RDEPEND="!net-proxy/v2ray-bin
23 BDEPEND=">=dev-lang/go-1.21.4"
26 sed -i 's|/usr/local/bin|/usr/bin|;s|/usr/local/etc|/etc|' release/config/systemd/system/*.service || die
27 sed -i '/^User=/s/nobody/v2ray/;/^User=/aDynamicUser=true' release/config/systemd/system/*.service || die
32 ego build -o v2ray -trimpath -ldflags "-s -w" ./main
39 newins release/config/config.json config.json.example
41 newinitd "${FILESDIR}/v2ray.initd-r1" v2ray
42 systemd_dounit release/config/systemd/system/v2ray{,@}.service