app-editors/appflowy-bin: add 0.7.4, drop 0.7.3
[gentoo-zh.git] / net-analyzer / nali / nali-0.8.1_p20240827.ebuild
blob73dc88047d07a830647a30f7c9edf533f682dea7
1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
5 inherit go-module
7 DESCRIPTION="An offline tool for querying IP geographic information and CDN provider."
8 HOMEPAGE="https://github.com/zu1k/nali"
9 EGIT_COMMIT="2e758d311739bc402ba63bda7ba081d565c0cf0f"
10 SRC_URI="
11 https://github.com/zu1k/nali/archive/${EGIT_COMMIT}.tar.gz -> ${P}.gh.tar.gz
12 https://github.com/peeweep/gentoo-go-deps/releases/download/${P}/${P}-vendor.tar.xz
15 S="${WORKDIR}/${PN}-${EGIT_COMMIT}"
16 LICENSE="MIT"
17 SLOT="0"
18 KEYWORDS="~amd64 ~arm64"
20 src_compile() {
21 local ldflags="\
22 -X \"github.com/zu1k/nali/internal/constant.Version=${PV}\" \
23 -w -s"
24 ego build -trimpath -ldflags "${ldflags}"
27 src_install() {
28 dobin ${PN}