app-editors/appflowy-bin: add 0.7.4, drop 0.7.3
[gentoo-zh.git] / net-dns / dog / dog-0.1.0-r1.ebuild
blob48738a03cefd5d129ba107171f92cf1904e0edd5
1 # Copyright 2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 # Autogenerated by pycargoebuild 0.13.2
6 EAPI=8
8 CRATES="
9 addr2line@0.14.0
10 adler@0.2.3
11 ansi_term@0.11.0
12 ansi_term@0.12.1
13 atty@0.2.14
14 autocfg@1.0.1
15 backtrace@0.3.54
16 bitflags@1.2.1
17 bitflags@2.5.0
18 byteorder@1.3.4
19 cc@1.0.98
20 cfg-if@0.1.10
21 cfg-if@1.0.0
22 core-foundation-sys@0.7.0
23 core-foundation@0.7.0
24 ctor@0.1.16
25 datetime@0.5.1
26 difference@2.0.0
27 failure@0.1.8
28 failure_derive@0.1.8
29 foreign-types-shared@0.1.1
30 foreign-types@0.3.2
31 getopts@0.2.21
32 getrandom@0.1.15
33 gimli@0.23.0
34 hermit-abi@0.1.17
35 httparse@1.3.4
36 ipconfig@0.2.2
37 itoa@0.4.6
38 json@0.12.4
39 lazy_static@1.4.0
40 libc@0.2.80
41 log@0.4.11
42 miniz_oxide@0.4.3
43 native-tls@0.2.4
44 object@0.22.0
45 once_cell@1.19.0
46 openssl-macros@0.1.1
47 openssl-probe@0.1.2
48 openssl-src@300.3.0+3.3.0
49 openssl-sys@0.9.102
50 openssl@0.10.64
51 output_vt100@0.1.2
52 pkg-config@0.3.19
53 ppv-lite86@0.2.10
54 pretty_assertions@0.6.1
55 proc-macro2@1.0.83
56 quote@1.0.36
57 rand@0.7.3
58 rand_chacha@0.2.2
59 rand_core@0.5.1
60 rand_hc@0.2.0
61 redox_syscall@0.1.57
62 regex-syntax@0.6.21
63 regex@1.4.2
64 remove_dir_all@0.5.3
65 rustc-demangle@0.1.18
66 ryu@1.0.5
67 schannel@0.1.19
68 security-framework-sys@0.4.3
69 security-framework@0.4.4
70 serde@1.0.117
71 serde_derive@1.0.117
72 serde_json@1.0.59
73 socket2@0.3.15
74 syn@1.0.48
75 syn@2.0.66
76 synstructure@0.12.4
77 tempfile@3.1.0
78 unicode-ident@1.0.12
79 unicode-width@0.1.8
80 unicode-xid@0.2.1
81 vcpkg@0.2.10
82 wasi@0.9.0+wasi-snapshot-preview1
83 widestring@0.4.3
84 winapi-i686-pc-windows-gnu@0.4.0
85 winapi-x86_64-pc-windows-gnu@0.4.0
86 winapi@0.3.9
87 winreg@0.6.2
90 declare -A GIT_CRATES=(
91 [mutagen-core]='https://github.com/llogiq/mutagen;c7abc956a10e8a3e2cc71f21279ea0a42f7b7c10;mutagen-%commit%/mutagen-core'
92 [mutagen-transform]='https://github.com/llogiq/mutagen;c7abc956a10e8a3e2cc71f21279ea0a42f7b7c10;mutagen-%commit%/mutagen-transform'
93 [mutagen]='https://github.com/llogiq/mutagen;c7abc956a10e8a3e2cc71f21279ea0a42f7b7c10;mutagen-%commit%/mutagen'
96 inherit cargo
98 DESCRIPTION="A command-line DNS client"
99 HOMEPAGE="https://dns.lookup.dog/"
100 SRC_URI="
101 https://github.com/ogham/dog/archive/tags/v${PV}.tar.gz -> ${P}.tar.gz
102 ${CARGO_CRATE_URIS}
104 S="${WORKDIR}/${PN}-tags-v${PV}"
106 LICENSE="EUPL-1.2"
107 # Dependent crate licenses
108 LICENSE+=" Apache-2.0 MIT Unicode-DFS-2016"
109 SLOT="0"
110 KEYWORDS="~amd64"
111 PATCHES=(
112 "${FILESDIR}/${P}-fix-openssl.patch"