1 # Copyright 1999-2022 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
8 DESCRIPTION="Dark Gtk3.20+ theme created using the awesome Nord color pallete"
9 HOMEPAGE="https://github.com/EliverLara/Nordic"
10 SRC_URI="https://github.com/EliverLara/Nordic/archive/v${PV}.tar.gz -> ${P}.tar.gz"
14 KEYWORDS="~amd64 ~x86"
15 IUSE="+gtk2 +gtk3 +gtk4 kde xfce mate gnome-shell cinnamon"
17 S="${WORKDIR}/Nordic-${PV}"
24 mv -v ./aurorae{,.old} || die
25 mkdir -pv ./aurorae/themes || die
26 mv -v ./aurorae.old/Nordic ./aurorae/themes/Nordic || die
27 mv -v ./colorschemes ./color-schemes || die
28 mv -v ./kvantum ./Kvantum || die
30 # remove broken symlinks
31 for file in $(find -L ./folders -type l)
33 if [ ! -d $file ]; then
37 mv -v ./folders ./icons || die
39 # requires media-gfx/inkscape & x11-apps/xcursorgen
40 # to build from sources
41 # GIMP with “X11 Mouse Cursor (XMC)” plugin
44 rm -rf ./cursors || die
46 mv -v ./sddm{,.old} || die
47 mkdir -pv ./sddm/themes || die
48 mv -v ./sddm.old ./sddm/themes/Nordic || die
52 src_configure() { :; }
57 insinto /usr/share/themes/Nordic-v40
58 doins -r ./{assets,index.theme}
59 use gtk2 && doins -r ./gtk-2.0
60 use gtk3 && doins -r ./gtk-3.0
61 use gtk4 && doins -r ./gtk-4.0
63 use xfce && doins -r ./xfwm4
64 use mate && doins -r ./metacity-1
65 use gnome-shell && doins -r ./gnome-shell
66 use cinnamon && doins -r ./cinnamon
76 use kde && optfeature "Kvantum theme support" x11-themes/kvantum