1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 inherit eutils subversion
8 DESCRIPTION
="Chrasis SCIM binding for chinese character recognition."
9 HOMEPAGE
="http://chrasis.berlios.de/"
17 DEPEND
=">=app-i18n/scim-1.2.0
18 >=x11-libs/gtk+-2.12.0
24 ESVN_REPO_URI
="svn://svn.berlios.de/chrasis/Linux/scim-chrasis/trunk"
25 ESVN_PROJECT
="scim-chrasis"
26 #ESVN_PATCHES="*.diff"
27 #ESVN_BOOTSTRAP="./autogen.sh"
34 econf
"$(use_enable nls)" || die
"Error: econf failed!"
38 emake || die
"Error: emake failed!"
42 make DESTDIR
="${D}" install || die
"Error: install failed!"
43 dodoc ChangeLog README
49 # elog "The SCIM input pad should be startable from the SCIM (and Skim)"
50 # elog "systray icon right click menu. You will have to restart SCIM"
51 # elog "(or Skim) in order for the menu entry to appear (you may simply"
52 # elog "restart your X server). If you want to use it immediately, just"
53 # elog "start the SCIM input pad, using the 'scim-input-pad' command."
55 # elog "To use, select the text zone you wish to write in, and just"
56 # elog "click on the wanted character in the right multilevel tabbed"
57 # elog "table, from the SCIM Input Pad interface."
59 # elog "To add new characters to the tables, see the documentation"
60 # elog "(/usr/share/doc/${PF}/README.gz)."