net-im/wemeet: fix media-libs/tiff depend
[gentoo-zh.git] / app-dicts / fcitx-pinyin-zhwiki / fcitx-pinyin-zhwiki-20230128.ebuild
blob3cf66d3791d1f5b39ad07b0b6b96d565c4909263
1 # Copyright 2022 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 MY_PN="zhwiki-${PV}.dict"
7 MY_PV="0.2.4"
9 RESTRICT="mirror"
11 DESCRIPTION="Fcitx 5 Pinyin Dictionary from zh.wikipedia.org"
12 HOMEPAGE="https://github.com/felixonmars/fcitx5-pinyin-zhwiki"
13 SRC_URI="https://github.com/felixonmars/fcitx5-pinyin-zhwiki/releases/download/${MY_PV}/${MY_PN} -> ${P}.dict"
15 LICENSE="Unlicense"
16 SLOT="5"
17 KEYWORDS="amd64 arm mips x86"
19 DEPEND=""
20 BDEPEND=""
21 RDEPEND="app-i18n/fcitx:5"
23 S="${DISTDIR}"
25 src_install(){
26 DICT_PATH="/usr/share/fcitx5/pinyin/dictionaries"
27 insinto ${DICT_PATH}
28 doins ${P}.dict
29 fperms 0644 "${DICT_PATH}/${P}.dict"