net-im/wemeet: fix media-libs/tiff depend
[gentoo-zh.git] / app-misc / gpick / gpick-0.2.6-r1.ebuild
blobe7b29b61d80aa483abd7665c4929123edd305463
1 # Copyright 1999-2022 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit cmake xdg
8 DESCRIPTION="Advanced color picker written in C++ using GTK+ toolkit"
9 HOMEPAGE="https://github.com/thezbyg/gpick"
10 SRC_URI="https://github.com/thezbyg/${PN}/archive/${P}.tar.gz"
12 LICENSE="BSD"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE="+gtk3 nls"
17 RDEPEND="
18 >=dev-lang/lua-5.2:=
19 dev-libs/boost
20 dev-libs/expat
21 dev-util/ragel
22 nls? ( sys-devel/gettext )
23 gtk3? ( x11-libs/gtk+:3 )
24 !gtk3? ( x11-libs/gtk+:2 )
27 DEPEND="${RDEPEND}"
29 S="${WORKDIR}/gpick-gpick-${PV}"
31 src_prepare() {
32 cmake_src_prepare
35 src_configure() {
36 local mycmakeargs=(
37 -DUSE_GTK3=$(usex gtk3 ON OFF)
38 -DENABLE_NLS=$(usex nls ON OFF)
40 cmake_src_configure
43 src_install() {
44 pushd "${BUILD_DIR}"
45 exeinto "/usr/$(get_libdir)"
46 local so
47 for so in *.so
49 doexe "${so}"
50 done
51 popd || die
53 cmake_src_install
55 mv "${D}/usr/share/doc/${PN}" "${D}/usr/share/doc/${P}" || die