net-proxy/yass: add 1.10.5, drop 1.10.4
[gentoo-zh.git] / media-sound / feeluown / feeluown-4.1.2.ebuild
blob91022553da05ebec8c93f61489704c4eec573b0d
1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
5 DISTUTILS_USE_PEP517=setuptools
6 PYTHON_COMPAT=( python3_{10..11} )
8 inherit distutils-r1 desktop
10 DESCRIPTION="A user-friendly and hackable music player"
11 HOMEPAGE="https://github.com/feeluown/FeelUOwn"
12 MY_P="${P/_alpha/a}"
13 MY_PV="${PV/_alpha/a}"
14 S="${WORKDIR}/FeelUOwn-${MY_PV}"
15 SRC_URI="https://github.com/${PN}/FeelUOwn/archive/refs/tags/v${MY_PV}.tar.gz -> ${MY_P}.gh.tar.gz"
17 LICENSE="GPL-3"
18 SLOT="0"
19 KEYWORDS="~amd64"
20 RESTRICT="test" # TODO
21 IUSE="+netease +qqmusic +webengine +ytmusic +bilibili +cookies"
23 RDEPEND="
24         dev-python/janus[${PYTHON_USEDEP}]
25         dev-python/requests[${PYTHON_USEDEP}]
26         dev-python/pyopengl[${PYTHON_USEDEP}]
27         dev-python/PyQt5[gui,widgets,opengl,svg,${PYTHON_USEDEP}]
28         dev-python/qasync[${PYTHON_USEDEP}]
29         dev-python/tomlkit[${PYTHON_USEDEP}]
30         dev-python/packaging[${PYTHON_USEDEP}]
31         >=dev-python/pydantic-1.10[${PYTHON_USEDEP}]
34 PDEPEND="
35         media-video/mpv[libmpv]
36         netease? ( dev-python/fuo-netease[${PYTHON_USEDEP}] )
37         qqmusic? ( dev-python/fuo-qqmusic[${PYTHON_USEDEP}] )
38         bilibili? ( dev-python/feeluown-bilibili[$PYTHON_USEDEP] )
39         ytmusic? ( dev-python/fuo-ytmusic[$PYTHON_USEDEP] )
40         webengine? ( dev-python/PyQtWebEngine[$PYTHON_USEDEP] )
41         cookies? ( dev-python/pycryptodome[$PYTHON_USEDEP] dev-python/secretstorage[$PYTHON_USEDEP] )
44 DEPEND="
45         ${RDEPEND}
46         ${PDEPEND}
47         dev-python/setuptools[${PYTHON_USEDEP}]
50 PATCHES=(
51         "${FILESDIR}"/${PN}-3.8.5-fix-mpv.patch # Remove unused ytdl option
54 python_install_all() {
55         distutils-r1_python_install_all
57         domenu "${FILESDIR}/${PN}.desktop"
58         newicon "${S}/feeluown/gui/assets/icons/feeluown.png" "${PN}.png"