1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
11 DESCRIPTION
="Advanced color picker written in C++ using GTK+ toolkit"
12 HOMEPAGE
="http://code.google.com/p/gpick/"
13 SRC_URI
="http://gpick.googlecode.com/files/${MY_P}.tar.gz"
17 KEYWORDS
="~x86 ~amd64"
18 IUSE
="debug unique dbus"
20 RDEPEND
=">=x11-libs/gtk+-2.12.0
22 dbus? ( >=dev-libs/dbus-glib-0.76 )
23 unique? ( >=dev-libs/libunique-1.0.8 )
27 >=dev-util/scons-1.0.0"
29 S
="${WORKDIR}/${MY_P}"
32 epatch
"${FILESDIR}"/fix_revision_information.
diff
35 use unique
&& WITH_UNIQUE
=yes
36 use dbus
&& WITH_DBUSGLIB
=yes
37 use debug
&& DEBUG
=yes
39 scons
${MAKEOPTS} build \
40 || die
"scons build failed"
44 scons DESTDIR
="${D}/usr" install || die
"scons install failed"
46 dosym
/usr
/share
/icons
/hicolor
/48x48
/apps
/gpick.png
/usr
/share
/pixmaps
/gpick.png