sys-kernel/liquorix-sources: Bump to new version, drop old version.
[gentoo-zh.git] / dev-python / imgviz / imgviz-1.3.0.ebuild
blobfcad6aaaff70432f8e5b1bb5a4a0f3c8e0b2be9b
1 # Copyright 2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 PYTHON_COMPAT=( python3_9 )
7 inherit distutils-r1
9 DESCRIPTION="mage Visualization Tools"
10 HOMEPAGE="https://github.com/wkentaro/imgviz"
11 SRC_URI="https://github.com/wkentaro/imgviz/archive/v${PV}.tar.gz -> ${P}.tar.gz"
13 LICENSE="MIT"
14 SLOT="0"
15 KEYWORDS="amd64 ~x86"
17 DEPEND="dev-python/matplotlib[${PYTHON_USEDEP}]
18 dev-python/numpy[${PYTHON_USEDEP}]
19 dev-python/pillow[${PYTHON_USEDEP}]
20 dev-python/QtPy[${PYTHON_USEDEP}]
21 dev-python/termcolor[${PYTHON_USEDEP}]
22 dev-python/pyyaml[${PYTHON_USEDEP}]
23 dev-python/setuptools[${PYTHON_USEDEP}]"
24 RDEPEND="${DEPEND}"
25 BDEPEND=""
27 distutils_enable_tests pytest