add fcixt5 news
[gentoo-zh.git] / sys-process / btop / btop-1.2.6.ebuild
blob1d9fc47891594e80fa9ffe52ec3598b8237c7865
1 # Copyright 1999-2022 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 DESCRIPTION="Resources monitor. The C++ version of bashtop"
8 HOMEPAGE="https://github.com/aristocratos/btop"
9 SRC_URI="https://github.com/aristocratos/btop/archive/v${PV}.tar.gz -> ${P}.tar.gz"
10 LICENSE="Apache-2.0 "
11 SLOT="0"
12 KEYWORDS="~amd64 ~x86"
13 IUSE=""
15 RDEPEND=""
17 DEPEND="${RDEPEND}"
19 BDEPEND="
20 >=sys-devel/gcc-10
23 S="${WORKDIR}/${PN}-${PV}"
25 src_prepare() {
26 default
27 # btop installs README.md to /usr/share/btop by default
28 sed -i 's/^.*cp -p README.md.*$//' Makefile || die
31 src_compile() {
32 # Disable btop optimization flags, since we have our flags in CXXFLAGS
33 emake \
34 OPTFLAGS=""
37 src_install() {
38 emake \
39 PREFIX="${EPREFIX}/usr" \
40 DESTDIR="${D}" \
41 install
43 dodoc README.md CHANGELOG.md