1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 LUA_COMPAT=( lua5-{3,4} )
8 inherit cmake lua xdg git-r3
10 EGIT_REPO_URI="https://github.com/fcitx/fcitx5-lua.git"
11 DESCRIPTION="Lua support for fcitx"
12 HOMEPAGE="https://github.com/fcitx/fcitx5-lua"
17 REQUIRED_USE="${LUA_REQUIRED_USE}"
18 RESTRICT="!test? ( test )"
30 kde-frameworks/extra-cmake-modules:0
36 -DCMAKE_INSTALL_LIBDIR="${EPREFIX}/usr/$(get_libdir)"
37 -DCMAKE_INSTALL_SYSCONFDIR="${EPREFIX}/etc"
38 -DUSE_DLOPEN=$(usex dlopen)
39 -DENABLE_TEST=$(usex test)