app-editors/typora: add 1.8.10, drop 1.7.6
[gentoo-zh.git] / app-i18n / fcitx-lua / fcitx-lua-9999.ebuild
blob8a91bfcbf308a608ed9407514ce79c84dd051621
1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 LUA_COMPAT=( lua5-{3,4} )
8 inherit cmake lua xdg git-r3
10 EGIT_REPO_URI="https://github.com/fcitx/fcitx5-lua.git"
11 DESCRIPTION="Lua support for fcitx"
12 HOMEPAGE="https://github.com/fcitx/fcitx5-lua"
14 LICENSE="LGPL-2.1+"
15 SLOT="5"
16 IUSE="+dlopen test"
17 REQUIRED_USE="${LUA_REQUIRED_USE}"
18 RESTRICT="!test? ( test )"
20 RDEPEND="
21         ${LUA_DEPS}
22         app-i18n/fcitx:5
25 DEPEND="
26         ${RDEPEND}
29 BDEPEND="
30         kde-frameworks/extra-cmake-modules:0
31         virtual/pkgconfig
34 src_configure() {
35         local mycmakeargs=(
36                 -DCMAKE_INSTALL_LIBDIR="${EPREFIX}/usr/$(get_libdir)"
37                 -DCMAKE_INSTALL_SYSCONFDIR="${EPREFIX}/etc"
38                 -DUSE_DLOPEN=$(usex dlopen)
39                 -DENABLE_TEST=$(usex test)
40         )
41         cmake_src_configure