app-editors/typora: add 1.8.10, drop 1.7.6
[gentoo-zh.git] / app-office / bytedance-feishu / bytedance-feishu-5.14.14.ebuild
blob0c956fc1e1bbfc91f39284d4f81ad09c99dd6997
1 # Copyright 2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 MULTILIB_COMPAT=( abi_mips_n64 )
8 inherit desktop unpacker xdg
10 CDN_URL="https://sf3-cn.feishucdn.com/obj/ee-appcenter/2844ab12b34f/"
12 DESCRIPTION="feishu - ByteDance's enterprise collaboration platform"
13 HOMEPAGE="https://www.feishu.cn/"
14 SRC_URI="
15         amd64?  ( ${CDN_URL}Feishu-linux_x64-${PV}.deb )
16         arm64?  ( ${CDN_URL}Feishu-linux_arm64-${PV}.deb )
17         mips?   ( ${CDN_URL}Feishu-linux_mips64el-${PV}.deb )
20 LICENSE="bytedance-feishu"
21 SLOT="0"
22 KEYWORDS="-* ~amd64 ~arm64 ~mips"
23 IUSE="big-endian"
24 REQUIRED_USE="mips? ( !big-endian )"
26 RDEPEND="
27         dev-libs/nss
28         dev-util/desktop-file-utils
29         media-libs/alsa-lib
30         net-print/cups
31         x11-libs/gtk+:3
32         x11-libs/libX11
33         x11-libs/libXext
34         x11-libs/libxcb
35         x11-libs/libxkbcommon
36         x11-misc/xdg-utils
37         dev-libs/wayland
40 S="${WORKDIR}"
41 QA_PREBUILT="*"
43 src_prepare() {
44         eapply_user
45         sed -i 's/Application;//g' usr/share/applications/bytedance-feishu.desktop || die
46         # rm -r usr/share/appdata || die
47         gzip -d "usr/share/man/man1/${PN}-stable.1.gz" || die
48         gzip -d "usr/share/doc/${PN}-stable/changelog.gz" || die
51 src_install() {
53         insinto "/"
54         doins -r "opt"
55         insinto "/usr/bin"
56         doins "usr/bin/bytedance-feishu-stable"
58         domenu "usr/share/applications/${PN}.desktop"
59         doman "usr/share/man/man1/${PN}-stable.1"
60         dodoc "usr/share/doc/${PN}-stable/changelog"
62         local size
63         for size in 16 24 32 48 64 128 256 ; do
64                 newicon -s ${size} "opt/bytedance/feishu/product_logo_${size}.png" ${PN}.png
65         done
67         fperms +x "/opt/bytedance/feishu/bytedance-feishu"
68         fperms +x "/opt/bytedance/feishu/feishu"
69         fperms +x "/opt/bytedance/feishu/vulcan/vulcan"
73 pkg_postinst(){
74         xdg_pkg_postinst