1 # Copyright 2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 MULTILIB_COMPAT=( abi_mips_n64 )
8 inherit desktop unpacker xdg
10 CDN_URL="https://sf3-cn.feishucdn.com/obj/ee-appcenter/2844ab12b34f/"
12 DESCRIPTION="feishu - ByteDance's enterprise collaboration platform"
13 HOMEPAGE="https://www.feishu.cn/"
15 amd64? ( ${CDN_URL}Feishu-linux_x64-${PV}.deb )
16 arm64? ( ${CDN_URL}Feishu-linux_arm64-${PV}.deb )
17 mips? ( ${CDN_URL}Feishu-linux_mips64el-${PV}.deb )
20 LICENSE="bytedance-feishu"
22 KEYWORDS="-* ~amd64 ~arm64 ~mips"
24 REQUIRED_USE="mips? ( !big-endian )"
28 dev-util/desktop-file-utils
45 sed -i 's/Application;//g' usr/share/applications/bytedance-feishu.desktop || die
46 # rm -r usr/share/appdata || die
47 gzip -d "usr/share/man/man1/${PN}-stable.1.gz" || die
48 gzip -d "usr/share/doc/${PN}-stable/changelog.gz" || die
56 doins "usr/bin/bytedance-feishu-stable"
58 domenu "usr/share/applications/${PN}.desktop"
59 doman "usr/share/man/man1/${PN}-stable.1"
60 dodoc "usr/share/doc/${PN}-stable/changelog"
63 for size in 16 24 32 48 64 128 256 ; do
64 newicon -s ${size} "opt/bytedance/feishu/product_logo_${size}.png" ${PN}.png
67 fperms +x "/opt/bytedance/feishu/bytedance-feishu"
68 fperms +x "/opt/bytedance/feishu/feishu"
69 fperms +x "/opt/bytedance/feishu/vulcan/vulcan"