1 # Copyright 2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 inherit systemd go-module
8 DESCRIPTION="A fork of trojan-go"
9 HOMEPAGE="https://github.com/Potterli20/trojan-go-fork"
11 https://github.com/Potterli20/trojan-go-fork/archive/refs/tags/V${PV}.tar.gz -> ${P}.tar.gz
12 https://github.com/peeweep/gentoo-go-deps/releases/download/${P}/${P}-vendor.tar.xz
20 app-alternatives/v2ray-geoip
21 app-alternatives/v2ray-geosite
24 BDEPEND=">=dev-lang/go-1.22"
27 ego build -tags "full"
32 dosym -r /usr/bin/trojan-go-fork /usr/bin/trojan-go
34 insinto /etc/trojan-go
37 systemd_dounit example/*.service
39 dosym -r /usr/share/v2ray/geosite.dat /usr/share/trojan-go/geosite.dat
40 dosym -r /usr/share/v2ray/geoip.dat /usr/share/trojan-go/geoip.dat