1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 PYTHON_COMPAT=( python3_{8..12} )
7 inherit python-single-r1 unpacker
9 DESCRIPTION="Deepin Wine Helper"
10 HOMEPAGE="https://www.deepin.org"
12 COMMON_URI="https://home-store-packages.uniontech.com/appstore/pool/appstore/d"
13 SRC_URI="${COMMON_URI}/${PN}/${PN}_${PV}-1_i386.deb"
18 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
28 QA_PREBUILT="opt/deepinwine/*"
29 QA_FLAGS_IGNORED="opt/deepinwine/*"
32 python_fix_shebang -f "opt/deepinwine/tools/add_hotkeys"
33 python_fix_shebang -f "opt/deepinwine/tools/get_tray_window"
37 fperms +x -R /opt/deepinwine/tools/