app-i18n/fcitx-skk: add 5.1.3, drop 5.1.2
[gentoo-zh.git] / dev-libs / lunar-calendar / lunar-calendar-3.0.1.ebuild
blob7dfde9eaa51162456e2e63874d0ef488bacc4708
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit meson
8 DESCRIPTION="a gtk+ calendar widget for chinese lunar library"
9 HOMEPAGE="https://github.com/yetist/lunar-calendar"
10 SRC_URI="https://github.com/yetist/lunar-calendar/archive/v${PV}.tar.gz -> ${P}.tar.gz"
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="amd64 x86"
15 IUSE="doc vala introspection test"
16 RESTRICT="!test? ( test )"
17 RDEPEND=">=dev-python/pygobject-2.11.5"
19 DEPEND="${RDEPEND}
20         dev-libs/lunar-date
21         dev-util/gdbus-codegen
22         sys-devel/gettext
23         virtual/pkgconfig
24         >=dev-util/intltool-0.35
25         doc? ( dev-util/gtk-doc )
26         vala? ( dev-lang/vala )
27         introspection? ( dev-libs/gobject-introspection )"
29 DOCS="COPYING NEWS README.md"
31 src_configure(){
32         local emesonargs=(
33                 $(meson_use doc docs)
34                 $(meson_use vala vapi)
35                 $(meson_use introspection introspection)
36                 $(meson_use test tests)
37         )
38         meson_src_configure
41 pkg_postinst(){
42         einfo
43         einfo "To make gtk applicants show lunar automaticly,"
44         einfo "set the two envirent variables."
45         einfo "GTK3_MODULES is for gtk3,and GTK_MODULES for gtk2."
46         einfo "For example,write the two lines to .xprofile"
47         einfo "export GTK3_MODULES=lunar-calendar-module"
48         einfo "export GTK_MODULES=lunar-calendar-module"
49         einfo