net-proxy/clash: version bump to 1.7.0 (#1188)
[gentoo-zh.git] / dev-libs / v2ray-domain-list-community-bin / v2ray-domain-list-community-bin-4.39.2_p20210621183458.ebuild
blob014437899c57264d31c4b3b1a1397f5f51925256
1 # Copyright 2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 DESCRIPTION="Community managed domain list for V2Ray."
7 HOMEPAGE="https://github.com/v2fly/domain-list-community"
8 if [[ ${PV} == *9999 ]]; then
9         PROPERTIES="live"
10         SRC_URI=
11 else
12         SRC_URI="https://github.com/v2fly/domain-list-community/releases/download/${PV#*_p}/dlc.dat.xz -> ${P}.dat.xz"
13         KEYWORDS="~amd64 ~arm ~arm64 ~x86"
15 S="${WORKDIR}"
17 LICENSE="MIT"
18 SLOT="0"
20 DEPEND=""
21 RDEPEND="${DEPEND}
22         !dev-libs/v2ray-domain-list-community
23         !<net-proxy/v2ray-4.38.3
25 BDEPEND=""
27 src_unpack() {
28         if [[ ${PV} == *9999 ]]; then
29                 wget "https://github.com/v2fly/domain-list-community/releases/latest/download/dlc.dat" || die
30                 wget "https://github.com/v2fly/domain-list-community/releases/latest/download/dlc.dat.sha256sum" || die
31                 sha256sum -c dlc.dat.sha256sum || die "check sha256sum for 'dlc.dat' failed"
32         else
33                 default
34                 mv ${P}.dat dlc.dat || die
35         fi
38 src_install() {
39         insinto /usr/share/v2ray
40         newins dlc.dat geosite.dat