1 # Copyright 2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 DESCRIPTION="Community managed domain list for V2Ray."
7 HOMEPAGE="https://github.com/v2fly/domain-list-community"
8 if [[ ${PV} == *9999 ]]; then
12 SRC_URI="https://github.com/v2fly/domain-list-community/releases/download/${PV#*_p}/dlc.dat.xz -> ${P}.dat.xz"
13 KEYWORDS="~amd64 ~arm ~arm64 ~x86"
22 !dev-libs/v2ray-domain-list-community
23 !<net-proxy/v2ray-4.38.3
28 if [[ ${PV} == *9999 ]]; then
29 wget "https://github.com/v2fly/domain-list-community/releases/latest/download/dlc.dat" || die
30 wget "https://github.com/v2fly/domain-list-community/releases/latest/download/dlc.dat.sha256sum" || die
31 sha256sum -c dlc.dat.sha256sum || die "check sha256sum for 'dlc.dat' failed"
34 mv ${P}.dat dlc.dat || die
39 insinto /usr/share/v2ray
40 newins dlc.dat geosite.dat