1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
5 DISTUTILS_USE_SETUPTOOLS=pyproject.toml
6 PYTHON_COMPAT=( python3_{8,9} pypy3 )
9 DESCRIPTION="Style-preserving TOML library for Python"
10 HOMEPAGE="https://github.com/sdispater/tomlkit"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
20 dev-python/setuptools[${PYTHON_USEDEP}]
22 dev-python/pytest[${PYTHON_USEDEP}]
27 sed -i -e '/{include = "tests", format = "sdist"}/d' pyproject.toml || die
28 sed -i -e 's/{include = "tomlkit"},/{include = "tomlkit"}/' pyproject.toml || die
30 distutils-r1_src_prepare
34 py.test -v || die "Tests fail with ${EPYTHON}"