net-proxy/clash: version bump to 1.7.0 (#1188)
[gentoo-zh.git] / net-proxy / v2ray-bin / v2ray-bin-4.34.0.ebuild
blobafdb8bddabec3a90257d93a6e7097dc93f77b766
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 MY_PV="v${PV}"
7 inherit systemd
9 DESCRIPTION="A platform for building proxies to bypass network restrictions."
10 HOMEPAGE="https://www.v2fly.org"
11 SRC_URI="
12 amd64? ( https://github.com/v2fly/v2ray-core/releases/download/$MY_PV/v2ray-linux-64.zip -> v2ray-$PV-linux-64.zip )
13 x86? ( https://github.com/v2fly/v2ray-core/releases/download/$MY_PV/v2ray-linux-32.zip -> v2ray-$PV-linux-32.zip )
14 arm? ( https://github.com/v2fly/v2ray-core/releases/download/$MY_PV/v2ray-linux-arm32-v7a.zip -> v2ray-$PV-linux-arm.zip )
15 arm? ( https://github.com/v2fly/v2ray-core/releases/download/$MY_PV/v2ray-linux-arm64-v8a.zip -> v2ray-$PV-linux-arm64.zip )
18 LICENSE="MIT"
19 SLOT="0"
20 KEYWORDS="~amd64 ~arm ~arm64 ~x86"
21 IUSE=""
23 DEPEND="!net-proxy/v2ray"
24 RDEPEND="${DEPEND}"
25 QA_PRESTRIPPED="
26 /usr/bin/v2ray
27 /usr/bin/v2ctl
30 src_unpack() {
31 if [ -n ${A} ]; then
32 unpack ${A}
34 S=${WORKDIR}
37 src_install() {
38 dobin v2ray
39 dobin v2ctl
41 insinto /usr/share/v2ray
42 doins *.dat
44 insinto /etc/v2ray
45 doins *.json
47 newinitd "${FILESDIR}/v2ray.initd" v2ray
48 systemd_dounit "${FILESDIR}/v2ray.service"
49 systemd_newunit "${FILESDIR}/v2ray_at.service" "v2ray@.service"