net-im/tencent-qq: rename version
[gentoo-zh.git] / app-i18n / fcitx5-skk / fcitx5-skk-9999.ebuild
blob54f831e8248556b48cde72b885e6a764165cdbf3
1 # Copyright 2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 if [[ "${PV}" =~ (^|\.)9999$ ]]; then
7 inherit git-r3
8 KEYWORDS=""
9 EGIT_REPO_URI="https://github.com/fcitx/fcitx5-skk"
10 else
11 KEYWORDS="~amd64 ~x86"
14 inherit xdg cmake
16 DESCRIPTION="Japanese SKK input engine for Fcitx5"
17 HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx5-skk"
18 if [[ "$PV" =~ (^|\.)9999$ ]]; then
19 SRC_URI=""
20 else
21 SRC_URI="https://download.fcitx-im.org/fcitx5/${PN}/${P}.tar.xz"
24 LICENSE="GPL-3+"
25 SLOT="5"
27 BDEPEND="kde-frameworks/extra-cmake-modules:5
28 virtual/pkgconfig"
30 RDEPEND="app-i18n/fcitx5
31 app-i18n/libskk
32 dev-qt/qtcore:5
33 app-i18n/fcitx5-qt[qt5,-only_plugin]
34 app-i18n/skk-jisyo
35 !app-i18n/fcitx-skk"
36 DEPEND="${RDEPEND}"
38 src_configure() {
39 local mycmakeargs=(
40 -DCMAKE_INSTALL_LIBDIR="${EPREFIX}/usr/$(get_libdir)"
42 cmake_src_configure