net-im/tencent-qq: rename version
[gentoo-zh.git] / app-i18n / scim-chrasis / scim-chrasis-9999.0.0.1.ebuild
blobda0769c8b53d617a37f4ec99a95e57536dfd480e
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 inherit eutils subversion
8 DESCRIPTION="Chrasis SCIM binding for chinese character recognition."
9 HOMEPAGE="http://chrasis.berlios.de/"
10 #SRC_URI=""
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS=""
15 IUSE="nls"
17 DEPEND=">=app-i18n/scim-1.2.0
18 >=x11-libs/gtk+-2.12.0
19 dev-libs/libchrasis"
21 RDEPEND="${DEPEND}"
23 src_unpack() {
24 ESVN_REPO_URI="svn://svn.berlios.de/chrasis/Linux/scim-chrasis/trunk"
25 ESVN_PROJECT="scim-chrasis"
26 #ESVN_PATCHES="*.diff"
27 #ESVN_BOOTSTRAP="./autogen.sh"
28 subversion_src_unpack
31 src_configure () {
32 glib-gettextize -f
33 ./autogen.sh
34 econf "$(use_enable nls)" || die "Error: econf failed!"
37 src_compile() {
38 emake || die "Error: emake failed!"
41 src_install() {
42 make DESTDIR="${D}" install || die "Error: install failed!"
43 dodoc ChangeLog README
46 #pkg_postinst() {
48 # elog
49 # elog "The SCIM input pad should be startable from the SCIM (and Skim)"
50 # elog "systray icon right click menu. You will have to restart SCIM"
51 # elog "(or Skim) in order for the menu entry to appear (you may simply"
52 # elog "restart your X server). If you want to use it immediately, just"
53 # elog "start the SCIM input pad, using the 'scim-input-pad' command."
54 # elog
55 # elog "To use, select the text zone you wish to write in, and just"
56 # elog "click on the wanted character in the right multilevel tabbed"
57 # elog "table, from the SCIM Input Pad interface."
58 # elog
59 # elog "To add new characters to the tables, see the documentation"
60 # elog "(/usr/share/doc/${PF}/README.gz)."
61 # elog