1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
5 PYTHON_COMPAT=( python3_{8,9} )
7 inherit python-r1 autotools git-r3
9 DESCRIPTION="Standalone lyrics fetcher/displayer (windowed and OSD mode)."
10 HOMEPAGE="https://github.com/osdlyrics/osdlyrics"
12 EGIT_REPO_URI="https://github.com/osdlyrics/osdlyrics.git"
18 if [[ "${PV}" != 9999 ]]; then
19 EGIT_COMMIT="818bac81ea3454bd9754602888203e0786cfd50b"
24 IUSE="gnome indicator"
29 dev-python/dbus-python[${PYTHON_USEDEP}]
30 dev-python/future[${PYTHON_USEDEP}]
31 dev-python/pygobject[${PYTHON_USEDEP}]
32 dev-python/pycurl[${PYTHON_USEDEP}]
33 gnome? ( dev-libs/gobject-introspection )
34 indicator? ( dev-libs/libappindicator )
51 --prefix="${EPREFIX}/usr" PYTHON="${PYTHON}"
55 python_foreach_impl run_in_build_dir configuring
59 python_foreach_impl run_in_build_dir default
63 python_foreach_impl run_in_build_dir default