net-im/tencent-qq: rename version
[gentoo-zh.git] / media-plugins / osdlyrics / osdlyrics-9999.ebuild
blob5e11eab3fab24fbf1c9e2f4d45f988f30c250f04
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
5 PYTHON_COMPAT=( python3_{8,9} )
7 inherit python-r1 autotools git-r3
9 DESCRIPTION="Standalone lyrics fetcher/displayer (windowed and OSD mode)."
10 HOMEPAGE="https://github.com/osdlyrics/osdlyrics"
12 EGIT_REPO_URI="https://github.com/osdlyrics/osdlyrics.git"
14 LICENSE="GPL-3"
15 SLOT="0"
16 KEYWORDS="~amd64"
18 if [[ "${PV}" != 9999 ]]; then
19         EGIT_COMMIT="818bac81ea3454bd9754602888203e0786cfd50b"
20 else
21         KEYWORDS=""
24 IUSE="gnome indicator"
26 RDEPEND="
27         x11-libs/libnotify
28         dev-libs/dbus-glib
29         dev-python/dbus-python[${PYTHON_USEDEP}]
30         dev-python/future[${PYTHON_USEDEP}]
31         dev-python/pygobject[${PYTHON_USEDEP}]
32         dev-python/pycurl[${PYTHON_USEDEP}]
33         gnome? ( dev-libs/gobject-introspection )
34         indicator? ( dev-libs/libappindicator )
37 DEPEND="
38         dev-util/intltool
39         ${RDEPEND}
42 src_prepare() {
43         default
44         eautoreconf
45         python_copy_sources
48 src_configure() {
49         configuring() {
50                 local myconf=(
51                         --prefix="${EPREFIX}/usr" PYTHON="${PYTHON}"
52                 )
53                 econf "${myconf[@]}"
54         }
55         python_foreach_impl run_in_build_dir configuring
58 src_compile() {
59         python_foreach_impl run_in_build_dir default
62 src_install() {
63         python_foreach_impl run_in_build_dir default