net-im/tencent-qq: rename version
[gentoo-zh.git] / net-proxy / smartproxy / smartproxy-0.9.4.ebuild
bloba28fcea364e74f8abf9128b3bff36224ef1f50d0
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 DESCRIPTION="A fast, proxy smart selector"
7 HOMEPAGE="https://github.com/microcai/smartproxy"
9 EGIT_REPO_URI="https://github.com/microcai/smartproxy"
10 EGIT_COMMIT="v${PV}"
12 inherit cmake git-r3
13 #SRC_URI="https://github.com/microcai/smartproxy/archive/v${PV}.tar.gz -> ${P}.tar.gz"
15 LICENSE="GPL-3+"
16 SLOT="0"
17 KEYWORDS="amd64 x86"
19 IUSE="system-boost"
21 RESTRICT="mirror"
23 RDEPEND="dev-libs/openssl"
25 DEPEND="dev-libs/openssl"
27 src_configure(){
28         local mycmakeargs=(
29                 -DUSE_SYSTEM_OPENSSL=ON
30         )
31         cmake_src_configure