dev-util/jetbrains-toolbox: add 2.5.1.34629, drop 2.4.2.32922
[gentoo-zh.git] / net-proxy / smartproxy / smartproxy-0.9.5.ebuild
blob4e9e64519b0e3a55aa4a97c37e35b5827e43ccd2
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 DESCRIPTION="A fast, proxy smart selector"
7 HOMEPAGE="https://github.com/microcai/smartproxy"
9 EGIT_REPO_URI="https://github.com/microcai/smartproxy"
10 EGIT_COMMIT="v${PV}"
12 inherit cmake
13 SRC_URI="
14 https://github.com/microcai/smartproxy/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
17 LICENSE="GPL-3+"
18 SLOT="0"
19 KEYWORDS="amd64 x86"
21 RDEPEND="dev-libs/openssl
24 DEPEND="dev-libs/openssl
27 src_configure(){
28 local mycmakeargs=(
29 -DUSE_SYSTEM_OPENSSL=ON
30 -DUSE_SYSTEM_BOOST=OFF
32 cmake_src_configure