net-proxy/daed: add 0.7.0, drop 0.6.0
[gentoo-zh.git] / dev-libs / libdwarf / libdwarf-20150507.ebuild
blob958949c8ff9aaed029b69ecd275ff01e03d50512
1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 #inherit
8 DESCRIPTION="Library to deal with DWARF Debugging Information Format"
9 HOMEPAGE="https://github.com/Distrotech/libdwarf"
10 SRC_URI="https://github.com/Distrotech/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
12 LICENSE="GPL-2 LGPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE="static-libs"
17 S="${WORKDIR}/${P}/${PN}"
19 # dirty hack, since I can't properly patch buildsystem
20 QA_PREBUILT="*/${PN}.so"
22 src_configure() {
23         econf --enable-shared
26 src_install() {
27         use static-libs && dolib.a libdwarf.a
28         dolib.so libdwarf.so
30         insinto /usr/include
31         doins libdwarf.h
33         dodoc NEWS README CHANGES