net-misc/rustdesk: bump version to 1.3.2
[gentoo-zh.git] / net-misc / ntpd-rs / ntpd-rs-1.3.0.ebuild
blobb81798a08e54e4755527e06c36f4e80d769eb997
1 # Copyright 2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 # Autogenerated by pycargoebuild 0.13.3
6 EAPI=8
8 CRATES="
9         addr2line@0.24.1
10         adler2@2.0.0
11         aead@0.5.2
12         aes-siv@0.7.0
13         aes@0.8.4
14         arbitrary@1.3.2
15         async-trait@0.1.82
16         backtrace@0.3.74
17         base64@0.22.1
18         bitflags@2.6.0
19         block-buffer@0.10.4
20         byteorder@1.5.0
21         bytes@1.7.2
22         cc@1.1.21
23         cfg-if@1.0.0
24         cipher@0.4.4
25         clock-steering@0.2.1
26         cmac@0.7.2
27         core-foundation-sys@0.8.7
28         core-foundation@0.9.4
29         cpufeatures@0.2.14
30         crypto-common@0.1.6
31         ctr@0.9.2
32         dbl@0.3.2
33         digest@0.10.7
34         equivalent@1.0.1
35         generic-array@0.14.7
36         getrandom@0.2.15
37         gimli@0.31.0
38         hashbrown@0.14.5
39         hermit-abi@0.3.9
40         indexmap@2.5.0
41         inout@0.1.3
42         itoa@1.0.11
43         lazy_static@1.5.0
44         libc@0.2.158
45         log@0.4.22
46         md-5@0.10.6
47         memchr@2.7.4
48         miniz_oxide@0.8.0
49         mio@1.0.2
50         nu-ansi-term@0.46.0
51         object@0.36.4
52         once_cell@1.19.0
53         openssl-probe@0.1.5
54         overload@0.1.1
55         pin-project-lite@0.2.14
56         ppv-lite86@0.2.20
57         proc-macro2@1.0.86
58         quote@1.0.37
59         rand@0.8.5
60         rand_chacha@0.3.1
61         rand_core@0.6.4
62         ring@0.17.8
63         rustc-demangle@0.1.24
64         rustls-native-certs@0.7.3
65         rustls-pemfile@2.1.3
66         rustls-pki-types@1.8.0
67         rustls-webpki@0.102.8
68         rustls@0.23.13
69         ryu@1.0.18
70         schannel@0.1.24
71         security-framework-sys@2.11.1
72         security-framework@2.11.1
73         serde@1.0.210
74         serde_derive@1.0.210
75         serde_json@1.0.128
76         serde_spanned@0.6.7
77         serde_test@1.0.177
78         sharded-slab@0.1.7
79         shlex@1.3.0
80         socket2@0.5.7
81         spin@0.9.8
82         subtle@2.6.1
83         syn@2.0.77
84         thread_local@1.1.8
85         timestamped-socket@0.2.5
86         tokio-macros@2.4.0
87         tokio-rustls@0.26.0
88         tokio@1.40.0
89         toml@0.8.19
90         toml_datetime@0.6.8
91         toml_edit@0.22.21
92         tracing-attributes@0.1.27
93         tracing-core@0.1.32
94         tracing-subscriber@0.3.18
95         tracing@0.1.40
96         typenum@1.17.0
97         unicode-ident@1.0.13
98         untrusted@0.9.0
99         version_check@0.9.5
100         wasi@0.11.0+wasi-snapshot-preview1
101         winapi-i686-pc-windows-gnu@0.4.0
102         winapi-x86_64-pc-windows-gnu@0.4.0
103         winapi@0.3.9
104         windows-sys@0.52.0
105         windows-sys@0.59.0
106         windows-targets@0.52.6
107         windows_aarch64_gnullvm@0.52.6
108         windows_aarch64_msvc@0.52.6
109         windows_i686_gnu@0.52.6
110         windows_i686_gnullvm@0.52.6
111         windows_i686_msvc@0.52.6
112         windows_x86_64_gnu@0.52.6
113         windows_x86_64_gnullvm@0.52.6
114         windows_x86_64_msvc@0.52.6
115         winnow@0.6.18
116         zerocopy-derive@0.7.35
117         zerocopy@0.7.35
118         zeroize@1.8.1
121 inherit cargo systemd
123 DESCRIPTION="Full-featured implementation of NTP with NTS support"
124 HOMEPAGE="https://github.com/pendulum-project/ntpd-rs"
125 SRC_URI="
126         ${CARGO_CRATE_URIS}
127         https://github.com/pendulum-project/ntpd-rs/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
130 S="${WORKDIR}/${P}/ntpd"
131 LICENSE="Apache-2.0 MIT"
132 # Dependent crate licenses
133 LICENSE+="
134         BSD ISC MIT Unicode-DFS-2016
135         || ( Apache-2.0 Boost-1.0 )
137 SLOT="0"
138 KEYWORDS="~amd64"
139 IUSE="metrics"
141 RDEPEND="
142         acct-group/ntpd-rs
143         acct-user/ntpd-rs
144         metrics? (
145                 acct-group/ntpd-rs-observe
146                 acct-user/ntpd-rs-observe
147         )
150 src_install(){
151         for bin in ntp-ctl ntp-daemon ntp-metrics-exporter; do
152                 dobin ../$(cargo_target_dir)/${bin}
153         done
155         for man in ntp-ctl.8  ntp-daemon.8  ntp-metrics-exporter.8  ntp.toml.5; do
156                 doman ../docs/precompiled/man/${man}
157         done
159         insinto $(systemd_get_systempresetdir)
160         doins ../docs/examples/conf/ntpd-rs.preset
162         insinto /etc/ntpd-rs
163         doins ../ntp.toml
165         systemd_dounit ../docs/examples/conf/ntpd-rs-metrics.service
166         systemd_dounit ../docs/examples/conf/ntpd-rs.service