1 # Copyright 2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 # Autogenerated by pycargoebuild 0.13.3
27 core-foundation-sys@0.8.7
55 pin-project-lite@0.2.14
64 rustls-native-certs@0.7.3
66 rustls-pki-types@1.8.0
71 security-framework-sys@2.11.1
72 security-framework@2.11.1
85 timestamped-socket@0.2.5
92 tracing-attributes@0.1.27
94 tracing-subscriber@0.3.18
100 wasi@0.11.0+wasi-snapshot-preview1
101 winapi-i686-pc-windows-gnu@0.4.0
102 winapi-x86_64-pc-windows-gnu@0.4.0
106 windows-targets@0.52.6
107 windows_aarch64_gnullvm@0.52.6
108 windows_aarch64_msvc@0.52.6
109 windows_i686_gnu@0.52.6
110 windows_i686_gnullvm@0.52.6
111 windows_i686_msvc@0.52.6
112 windows_x86_64_gnu@0.52.6
113 windows_x86_64_gnullvm@0.52.6
114 windows_x86_64_msvc@0.52.6
116 zerocopy-derive@0.7.35
121 inherit cargo systemd
123 DESCRIPTION="Full-featured implementation of NTP with NTS support"
124 HOMEPAGE="https://github.com/pendulum-project/ntpd-rs"
127 https://github.com/pendulum-project/ntpd-rs/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
130 S="${WORKDIR}/${P}/ntpd"
131 LICENSE="Apache-2.0 MIT"
132 # Dependent crate licenses
134 BSD ISC MIT Unicode-DFS-2016
135 || ( Apache-2.0 Boost-1.0 )
145 acct-group/ntpd-rs-observe
146 acct-user/ntpd-rs-observe
151 for bin in ntp-ctl ntp-daemon ntp-metrics-exporter; do
152 dobin ../$(cargo_target_dir)/${bin}
155 for man in ntp-ctl.8 ntp-daemon.8 ntp-metrics-exporter.8 ntp.toml.5; do
156 doman ../docs/precompiled/man/${man}
159 insinto $(systemd_get_systempresetdir)
160 doins ../docs/examples/conf/ntpd-rs.preset
165 systemd_dounit ../docs/examples/conf/ntpd-rs-metrics.service
166 systemd_dounit ../docs/examples/conf/ntpd-rs.service