dev-util/cargo-about: add 0.6.6, drop 0.6.4
[gentoo-zh.git] / net-dns / dog / dog-0.1.0_p20211007-r1.ebuild
blob82f38221d3e5985f03f91d019efb6e3ec93e9a4a
1 # Copyright 2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 # Autogenerated by pycargoebuild 0.13.2
6 EAPI=8
8 CRATES="
9         addr2line@0.14.1
10         adler@1.0.2
11         aho-corasick@0.7.18
12         ansi_term@0.12.1
13         atty@0.2.14
14         autocfg@1.0.1
15         backtrace@0.3.56
16         base64@0.13.0
17         bitflags@1.2.1
18         bumpalo@3.7.0
19         byteorder@1.4.3
20         cc@1.0.67
21         cfg-if@1.0.0
22         core-foundation-sys@0.8.2
23         core-foundation@0.9.1
24         ctor@0.1.20
25         darling@0.13.0
26         darling_core@0.13.0
27         darling_macro@0.13.0
28         datetime@0.5.1
29         diff@0.1.12
30         display_utils@0.4.0
31         env_logger@0.9.0
32         failure@0.1.8
33         failure_derive@0.1.8
34         fnv@1.0.7
35         foreign-types-shared@0.1.1
36         foreign-types@0.3.2
37         getopts@0.2.21
38         getrandom@0.2.2
39         gimli@0.23.0
40         hermit-abi@0.1.18
41         httparse@1.3.5
42         humantime@2.1.0
43         ident_case@1.0.1
44         ipconfig@0.2.2
45         itoa@0.4.7
46         js-sys@0.3.49
47         json@0.12.4
48         lazy_static@1.4.0
49         libc@0.2.91
50         log@0.4.14
51         matches@0.1.8
52         memchr@2.4.1
53         minimal-lexical@0.1.3
54         miniz_oxide@0.4.4
55         native-tls@0.2.7
56         nom@7.0.0
57         object@0.23.0
58         once_cell@1.7.2
59         openssl-probe@0.1.2
60         openssl-src@111.15.0+1.1.1k
61         openssl-sys@0.9.61
62         openssl@0.10.33
63         output_vt100@0.1.2
64         pkg-config@0.3.19
65         ppv-lite86@0.2.10
66         pretty_assertions@0.7.2
67         proc-macro2@1.0.29
68         quote@1.0.9
69         rand@0.8.3
70         rand_chacha@0.3.0
71         rand_core@0.6.2
72         rand_hc@0.3.0
73         redox_syscall@0.1.57
74         redox_syscall@0.2.5
75         regex-syntax@0.6.25
76         regex@1.5.4
77         remove_dir_all@0.5.3
78         ring@0.16.20
79         rustc-demangle@0.1.18
80         rustls@0.19.1
81         rustversion@1.0.5
82         ryu@1.0.5
83         schannel@0.1.19
84         sct@0.6.1
85         security-framework-sys@2.2.0
86         security-framework@2.2.0
87         serde@1.0.130
88         serde_derive@1.0.130
89         serde_json@1.0.68
90         serde_with@1.10.0
91         serde_with_macros@1.5.0
92         socket2@0.3.19
93         spin@0.5.2
94         strsim@0.10.0
95         syn@1.0.77
96         synstructure@0.12.4
97         tempfile@3.2.0
98         termcolor@1.1.2
99         unic-char-property@0.9.0
100         unic-char-range@0.9.0
101         unic-common@0.9.0
102         unic-idna-mapping@0.9.0
103         unic-idna-punycode@0.9.0
104         unic-idna@0.9.0
105         unic-normal@0.9.0
106         unic-ucd-bidi@0.9.0
107         unic-ucd-hangul@0.9.0
108         unic-ucd-normal@0.9.0
109         unic-ucd-version@0.9.0
110         unicode-width@0.1.8
111         unicode-xid@0.2.1
112         untrusted@0.7.1
113         vcpkg@0.2.11
114         version_check@0.9.3
115         wasi@0.10.2+wasi-snapshot-preview1
116         wasm-bindgen-backend@0.2.72
117         wasm-bindgen-macro-support@0.2.72
118         wasm-bindgen-macro@0.2.72
119         wasm-bindgen-shared@0.2.72
120         wasm-bindgen@0.2.72
121         web-sys@0.3.49
122         webpki-roots@0.21.1
123         webpki@0.21.4
124         widestring@0.4.3
125         winapi-i686-pc-windows-gnu@0.4.0
126         winapi-util@0.1.5
127         winapi-x86_64-pc-windows-gnu@0.4.0
128         winapi@0.3.9
129         winreg@0.6.2
132 declare -A GIT_CRATES=(
133         [mutagen-core]='https://github.com/llogiq/mutagen;933bbaf4edaa22f6237b2201dff2940ff7f4193c;mutagen-%commit%/mutagen-core'
134         [mutagen-transform]='https://github.com/llogiq/mutagen;933bbaf4edaa22f6237b2201dff2940ff7f4193c;mutagen-%commit%/mutagen-transform'
135         [mutagen]='https://github.com/llogiq/mutagen;933bbaf4edaa22f6237b2201dff2940ff7f4193c;mutagen-%commit%/mutagen'
138 inherit cargo
140 DESCRIPTION="A command-line DNS client"
141 HOMEPAGE="https://dns.lookup.dog/"
142 EGIT_COMMIT="721440b12ef01a812abe5dc6ced69af6e221fad5"
143 SRC_URI="
144         https://github.com/ogham/dog/archive/${EGIT_COMMIT}.tar.gz -> ${P}.gh.tar.gz
145         https://github.com/peeweep/gentoo-go-deps/releases/download/${P}/pr-83-add-scvb-and-https-support.patch
146         ${CARGO_CRATE_URIS}
149 S="${WORKDIR}/${PN}-${EGIT_COMMIT}"
151 LICENSE="EUPL-1.2"
152 # Dependent crate licenses
153 LICENSE+=" Apache-2.0 ISC MIT MPL-2.0"
154 SLOT="0"
155 KEYWORDS="~amd64"
156 PATCHES=(
157         "${FILESDIR}/${PN}-0.1.0-fix-openssl.patch"
158         "${DISTDIR}/pr-83-add-scvb-and-https-support.patch"