dev-util/cargo-about: add 0.6.6, drop 0.6.4
[gentoo-zh.git] / x11-misc / ly / ly-9999.ebuild
blob6e2530a5e78fa7bbe6f0652da41f515875f47fae
1 # Copyright 2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit systemd
8 DESCRIPTION="Ly - a TUI display manager"
9 HOMEPAGE="https://github.com/nullgemm/ly"
11 if [ "${PV}" = "9999" ]; then
12         EGIT_REPO_URI="https://github.com/nullgemm/ly.git"
13         EGIT_CLONE_TYPE="shallow"
14         inherit git-r3
15 else
16         KEYWORDS="~amd64"
18         # Latest hash of each submodule's master branch
19         ARGOAT="e1844c4c94b70bb351ec2bd2ac6bb320ee793d8f"
20         CONFIGATOR="8cec1786196ae6f6a8b35e66181277457f2a2bb2"
21         DRAGONFAIL="15bd3299bf3e49bd6734bff385cb0392cd2fa502"
22         TERMBOX="d961a8122210010e7c2c8f201e61170c13d319b4"
23         # This is a submodule for a submodule(argoat)
24         TESTOASTERROR="ee7c9d031d4632a6f381a6c174a38539bac04068"
26         SRC_URI="https://github.com/nullgemm/ly/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
27         https://github.com/nullgemm/argoat/archive/${ARGOAT}.tar.gz -> argoat.tar.gz
28         https://github.com/nullgemm/configator/archive/${CONFIGATOR}.tar.gz -> configator.tar.gz
29         https://github.com/nullgemm/dragonfail/archive/${DRAGONFAIL}.tar.gz -> dragonfail.tar.gz
30         https://github.com/nullgemm/termbox_next/archive/${TERMBOX}.tar.gz -> termbox_next.tar.gz
31         https://github.com/nullgemm/testoasterror/archive/${TESTOASTERROR}.tar.gz -> testoasterror.tar.gz
32         "
35 SUB="${S}/sub"
36 RES="${S}/res"
38 LICENSE="WTFPL-2"
39 SLOT="0"
41 DEPEND="sys-libs/pam
42 x11-libs/libxcb
43 x11-base/xorg-server
44 x11-apps/xauth"
46 RDEPEND="${DEPEND}"
48 src_unpack() {
49         if [[ ${PV} == 9999 ]]; then
50                 git-r3_src_unpack
51         else
52                 default
54                 mv "argoat-${ARGOAT}/"* "${SUB}/argoat" || die
55                 mv "testoasterror-${TESTOASTERROR}/"* "${SUB}/argoat/sub/testoasterror" || die
56                 mv "configator-${CONFIGATOR}/"* "${SUB}/configator" || die
57                 mv "dragonfail-${DRAGONFAIL}/"* "${SUB}/dragonfail" || die
58                 mv "termbox_next-${TERMBOX}/"* "${SUB}/termbox_next" || die
59         fi
62 src_install(){
63         default
65         newinitd "${RES}/${PN}-openrc" ly
66         systemd_dounit "${RES}/${PN}.service"
69 pkg_postinst() {
70         systemd_reenable "${PN}.service"
72         ewarn
73         ewarn "The init scripts are installed only for systemd/openrc"
74         ewarn "If you are using something else like runit etc."
75         ewarn "Please check upstream for get some help"
76         ewarn "If you are using a window manager as DWM"
77         ewarn "Please make sure there is a .desktop file in /usr/share/xsessions for it"