media-gfx/zwcad: fix fcitx problem
[gentoo-zh.git] / sci-chemistry / vesta / vesta-3.5.5.ebuild
blobcdabc68a3f08dbe9bd0e4af2b78a3645bc85ff65
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 inherit desktop xdg
8 DESCRIPTION="Visualization for Electronic and STructural Analysis"
9 HOMEPAGE="https://jp-minerals.org/vesta"
10 SRC_URI="https://jp-minerals.org/vesta/archives/${PV}/VESTA-gtk3.tar.bz2 -> ${PN}-${PV}.tar.bz2"
12 LICENSE="VESTA"
13 SLOT="0"
14 KEYWORDS="~amd64"
15 IUSE=""
17 RESTRICT="mirror strip"
19 DEPEND=""
20 RDEPEND="
21 x11-libs/gtk+
22 virtual/glu
23 dev-util/desktop-file-utils
24 x11-libs/libXtst
25 virtual/jdk
26 ${DEPEND}"
27 BDEPEND=""
29 S="${WORKDIR}/VESTA-gtk3"
31 QA_PREBUILT="*"
33 src_install() {
34 insinto /opt/VESTA
35 doins -r *
36 fperms +x /opt/VESTA/VESTA
37 fperms +x /opt/VESTA/VESTA-gui
39 domenu "${FILESDIR}/VESTA.desktop"
41 dosym ../VESTA/VESTA /opt/bin/VESTA
42 dosym ../VESTA/VESTA /opt/bin/vesta
45 pkg_postinst() {
46 xdg_desktop_database_update
48 elog "If you meet any abnormal behavior while using VESTA after upgrade or downgrade,"
49 elog "try remove ~/.VESTA and restart VESTA. Note that this will make you lost"
50 elog "all your saved configs."
53 pkg_postrm() {
54 xdg_desktop_database_update