dev-cpp/date: update SRC_URI
[gentoo-zh.git] / net-misc / aliyunpan / aliyunpan-0.2.8.ebuild
blob0280b5c4d177d2cd68fd1ddcd96832c34c32cb09
1 # Copyright 1999-2022 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit go-module
8 HOMEPAGE="https://github.com/tickstep/aliyunpan"
9 DESCRIPTION="aliyunpan cli client, support Webdav service, JavaScript plugin"
11 LICENSE="Apache-2.0"
12 SLOT="0"
13 KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc64 ~s390 ~x86"
14 SRC_URI="https://github.com/tickstep/aliyunpan/archive/v${PV}.tar.gz -> ${P}.tar.gz
15 https://github.com/123485k/gentoo-go-deps/releases/download/${P}/${P}-deps.tar.xz"
17 src_compile() {
18 ego build -o bin/${PN} -trimpath
21 src_install() {
22 dobin bin/${PN}
25 pkg_postinst() {
26 elog "if you see \"FATAL ERROR: config file error: config file permission denied\""
27 elog "try \"mkdir ~/.aliyunpan\""